Open link in new window launches empty page.

VERIFIED WORKSFORME

Status

P3
critical
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: jelwell, Assigned: alecf)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
On the latest build 1999120308 on WinNT.
1) Load up a webpage, say http://www.mozilla.org/
2) Now right click on a link
3) Select Open link in new window

Expected Results:
A new window is spawned.
New window displays the link page.
Sidebar ("My Panels") contains same preferences as before. (tinderbox, bookmarks
and what's related)

Actual Results:
A new window is spawned.
New window is blank.
Sidebar shows the "My Panels" and customize button, but selections (tinderbox,
bookmarks, and what's related) are missing.

The console says:
"Setting content window
browser.startup.page = 1
startpage = http://www.mozilla.org/
Javascript Error: TypeError: window.content.location has no properties
URL: chrome://navigator/content/navigator.js
LineNo: 419"

There are 4 of these errors, all the same except line #s 419, 461, 419, 461.
(Reporter)

Comment 1

19 years ago
It's clear that this bug is also causing "View Page Source" to come up blank...
As it spits out the same error messages.
(Reporter)

Comment 2

19 years ago
hmmm. wondering if bookmarks don't work for the same reason.
Try going to a bookmark... Mozilla goes no where and the console spits out the
same error message, only line 861 this time.
someone munged navigator.js or something horrific last night. ;)
(Assignee)

Updated

19 years ago
Target Milestone: M14
(Assignee)

Comment 3

19 years ago
can you try this with a normal browser window? I can't imagine this is a dom
viewer problem.
(Reporter)

Updated

19 years ago
Severity: normal → critical
Component: DOM Viewer → Browser-General
Target Milestone: M14 → M12
(Reporter)

Comment 4

19 years ago
I think I just misplaced the component. I don't know who to assign it to. I did
use the regular browser to test this...
As this seems to be a regression bug I don't think it should be pushed off to
M14 either. Remarking M12.
And marking critical because I think a browser that can't goto bookmarks is
worthless.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

19 years ago
WORKSFORME now. I think there were some issues possibly ironed out in bug 20714
that were causing lots of problems on the 1999120308 release.
(Reporter)

Comment 6

19 years ago
marking verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.