If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

campusi.com - JavaScript erases password field when tabbing out of field box

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P4
minor
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Mike Roberto, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030515 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030515 Mozilla Firebird/0.6

The only way i can check my pop mail on www.campusi.com is if i put my username
in, tab down, enter my password, and then press the enter key.  If I tab down to
the "Check My Mail" button, it clears out the password.  The same happens if I
use my mouse to click it.

Reproducible: Always

Steps to Reproduce:
1. Go to the site
2. Put in username and password
3. Tab down or click "Check My Mail"

Actual Results:  
The password clears out

Expected Results:  
The password should stay in and let me click the button.

Comment 1

15 years ago
This can be also reproduced using latest SeaMonkey Gecko/20030527 => should be
filed against Product "Browser" after checking for possible dupes and inspecting
the coding of the page...

Comment 2

15 years ago
Here's why:

The BODY tag contains onFocus="pgFocused()"

pgFocused contains:

function pgFocused() {

	var     f = document.form_email;
	var	f2 = document.form_srch;

	f.pswd.value	= '';

	f2.creditCardPref.selectedIndex	= 0;

	if (trim(f.emailAddr.value) == '' && trim(f2.srchTxt.value) == '') {
		f.emailAddr.focus();
	}
}

f.pswd is the password field.

So when you tab out of the password field:
1) The body receives focus
2) pgFocused() fires and erases the password field

As I understand it, this is correct behavior so I am marking this a Tech Evang
bug.  Anyone who disagrees, please reassign.
Assignee: blaker → aruner
Status: UNCONFIRMED → NEW
Component: General → US Ecommerce
Ever confirmed: true
Priority: -- → P4
Product: Phoenix → Tech Evangelism
QA Contact: asa → bc
Summary: Password form on main page disappears if user presses tab or clicks "Check My Mail" button → campusi.com - JavaScript erases password field when tabbing out of field box

Comment 3

15 years ago
tech evang june 2003 reorg
Assignee: aruner → english-us
Component: US Ecommerce → English US
QA Contact: bc → english-us
(Reporter)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.