In Mozilla, this URL gives an incorrect price. In IE, it gives the correct price.

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: sam.baker, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

http://www.digitalriver.com/dr/v2/ec_MAIN.Entry17c?CID=77647&SID=38712&SP=10007&PN=21&PID=1054912
is an offer for some software for sale at a special price.  In Mozilla 1.4b, the
price total is $69.99.  In Internet Explorer, the price total is $59.99, which
is correct.  This could be IE's fault, not Mozilla's.  IE may send requests in a
non-standard way, such as by changing capitalization, and the merchant's server
may be expecting that.  I have contacted the merchant.
BTW, I am not endorsing this software.

Reproducible: Always

Steps to Reproduce:
1.  Load the URL 
http://www.digitalriver.com/dr/v2/ec_MAIN.Entry17c?CID=77647&SID=38712&SP=10007&PN=21&PID=1054912

2.  The merchant says that this offer expires May 31, so you may not be able to
reproduce the error after that date.

Actual Results:  
The price total shown is $69.99.

Expected Results:  
The price total should be $59.99.


The workaround is to use Internet Explorer instead.

Comment 1

16 years ago
I see $59.99 on both IE and Mozilla

Comment 2

16 years ago
In 1.3 the browser displayed $69.99, but on May 26 build it displays as $59.99,
so it works for me.
(Reporter)

Comment 3

16 years ago
If the new build displays the price correctly, this bug report can be withdrawn.
 Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

16 years ago
If the new build displays the price correctly, this bug report can be withdrawn.
 Thanks!

Comment 5

16 years ago
reopening as no specific patch fixed this issue.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 6

16 years ago
Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.