form text size attribute works incorrectly

RESOLVED DUPLICATE of bug 102440

Status

()

defect
RESOLVED DUPLICATE of bug 102440
16 years ago
16 years ago

People

(Reporter: gshier, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3.1) Gecko/20030425

When I <INPUT TYPE=text NAME=f1 SIZE=2 MAXWIDTH=2 VALUE="AB">, I get a field
that is apparently 0 chars longs.  When I change to SIZE=50, I get approx 5
characters long.

Reproducible: Always

Steps to Reproduce:
<HTML><BODY><FORM NAME=a ACTION=a.cgi METHOD=post><INPUT TYPE=text NAME=f1
SIZE=2 MAXWIDTH=2 VALUE="AB"></FORM></BODY></HTML>

Actual Results:  
Mozilla displays a field that is too thin to see the value.

Expected Results:  
It should have displayed a field that was 2 characters wide.

Comment 1

16 years ago
This is happening because you're tripping over another bug regarding your use of
maxwidth, which is invalid -- there is no "maxwidth" property for INPUT tags in
HTML.  (The attribute you want is "maxlength".)

*** This bug has been marked as a duplicate of 102440 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.