[blocker][DOGFOOD] password dialog in mail doesn't work/go away

VERIFIED FIXED

Status

()

Core
XUL
P3
blocker
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Alec Flett, Assigned: travis)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
bring up mail, and you get a funny looking password dialog. It doesn't go away
and mozilla starts taking up 100% CPU time

you get this on the screen:
JavaScript Error: TypeError: window.arguments has no properties
URL: chrome://global/content/commonDialog.js

so it looks like window.arguments is broken

Travis is looking into this.

Comment 1

18 years ago
I see the following errors when trying to bring up an alert:

before clearItemSelection
JavaScript Error: TypeError: window.frames["messagepane"] has no properties
URL: chrome://messenger/content/msgMail3PaneWindow.js
LineNo: 453

JavaScript Error: TypeError: window.frames["messagepane"] has no properties
URL: chrome://messenger/content/msgMail3PaneWindow.js
LineNo: 453

So I suspect it's window.* that's broken, or at least more than window.arguments

Updated

18 years ago
OS: Linux → All
Hardware: PC → All

Comment 2

18 years ago
I see this on Mac as well; set platform/os to all.

alecf--do you also see this problem (below) or do you think it's a different bug?
I am having problems with buttons still (even after Travis' fix).
Here are the steps I tried:
 * From navigator window, Edit Preferences
 * Click on "Navigator" (click it again if it doesn't display pane)
 * Change Navigator starts with by clicking a different radio button
 * Click OK (nothing happens--I expect window to go away)
(Reporter)

Comment 3

18 years ago
adding waterson, because he's fixing some window event/JS stuff, may be related.
(Reporter)

Comment 4

18 years ago
bienvenu - make sure you have the latest (as of 11:41) changes from mozilla/dom
and mozilla/rdf/content

Updated

18 years ago
Assignee: travis → waterson

Comment 5

18 years ago
waterson testing fix, over to him.

Comment 6

18 years ago
20714 could be the same root cause.
*** Bug 20745 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Assignee: waterson → travis

Comment 8

18 years ago
travis has fix, back to him.

Updated

18 years ago
Severity: normal → blocker

Updated

18 years ago
Summary: [blocker] password dialog in mail doesn't work/go away → [blocker][DOGFOOD] password dialog in mail doesn't work/go away
(Reporter)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

18 years ago
travis has fixed, marking FIXED for all who are following this.
update mozilla/dom

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 10

18 years ago
verified
You need to log in before you can comment on or make changes to this bug.