different browsers insist on sharing same profiles/preferences

VERIFIED DUPLICATE of bug 107694

Status

SeaMonkey
Startup & Profiles
VERIFIED DUPLICATE of bug 107694
15 years ago
13 years ago

People

(Reporter: Steve W., Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

I currently use mozilla as my default browser in Win98-SE (my current default
OS). It does not support get-right as an FTP client, thus I have been forced to
install Netscape7 to get this feature. I wish to use a differing set of
profiles/preferences for Netscape, but it insists on using the Mozilla
profile/preferences. I set Netscape's prefs the way I wish it to act, and when I
went to use Mozilla it insisted on using the prefs I had just set in Netscape
(loosing all my bookmarks in the process.. ARGH!).
Additionally, I have been unable to get the two to use separate folders to store
their prefs/profiles in.
Added further, I have WinXP-Pro installed on the D:\ partition, and when I
installed a separate Mozilla there, it insisted on using the prefs/profiles from
C: partition! I do not yet know if the prefs I stored there have been changed..

Reproducible: Always

Steps to Reproduce:
1.Install Mozilla on C: (Win98-SE) and set the default preferences the way you wish.

2.Install Netscape on the same partition. It defaults to the same prefs set in
Mozilla. Reset Netscape default preferences to what you wish IT to use,
including storage in the Netscape\ folder. Exit Netscape.

3. Open Mozilla and find it has changed its default preferences to those just
reset in Netscape. Note that bookmarks in Mozilla have now been lost! (ARGH!)

4. Reset Mozilla default preferences. Save them to new directory (on same or
different partition) and exit.

5. Boot Netscape and find it has changed defaults to compliance with Mozilla!
Actual Results:  
Mozilla and Netscape are different browsers! (YES I am aware they use the same
engine.) Yet they insist on using the same set of default preferences/profiles.
They also insist on using a common directory to store them..

Expected Results:  
Allow Mozilla to use a different set of default profiles/preferences than
Netscape, and store them in a separate folder.

The 2 browsers also insist on using the same directories for cache and
histories. This becomes mildly annoying when the 2 browsers are used for
different purposes, and you go looking for the last site visited in Netscape but
find you must go through 3 days worth of surfing in Mozilla! There also seems to
be no differentiation between the 2 browsers within the history list..

Comment 1

15 years ago
You must create one profile for each browser.

*** This bug has been marked as a duplicate of 107694 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.