The default bug view has changed. See this FAQ.

some pdf files do not print at all using the latest adobe acrobat reader 6.0

RESOLVED WONTFIX

Status

Plugins Graveyard
PDF (Adobe)
--
major
RESOLVED WONTFIX
14 years ago
11 months ago

People

(Reporter: theramf, Assigned: Peter Lubczynski)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.4b) Gecko/20030507

Some PDF files do not print at all using the latest Adobe Acrobat Reader 6.0
plug-in.  There is no error message displayed.  The plug-in appears to go
through the expected print dialogs, but the "printing" progress bar fills much
faster than expected, and no document is sent to the print queue.  These
documents print correctly when "Save as copy" is used and they are opened in the
standalone (non-plug-in) viewer.  See
http://www2.arthroscopyjournal.org/scripts/om.dll/serve?action=get-media&id=jar030195ia&trueID=pdf_ar030195ia&location=jar030195&type=pdf&name=x.pdf
for an example PDF.


Reproducible: Always

Steps to Reproduce:
1. Install Adobe Reader 6.0
2. Load the example pdf in Mozilla
3. Attempt to print the document

Actual Results:  
The document does not print.  No errors are given.  No program crashes occur.

Expected Results:  
The document should have printed out.
(Reporter)

Updated

14 years ago
OS: Windows 98 → Windows ME
(Assignee)

Comment 1

14 years ago
does Acrobat 5.0 print?
(Reporter)

Comment 2

14 years ago
Yes, both Acrobat 5.0 and Acrobat 5.1 print perfectly.
(Reporter)

Comment 3

14 years ago
I'm not sure if this is a directly related problem or not, but I just realized
today that the "Search" feature in Acrobat 6.0 is suffering from a similar
problem.  Text searches for words that are definitely within the PDF document
produce no hits from within the browser.  The search proceeds much faster than
expected as well.  Like the print problem, the search issue can be successfully
worked around by using "Save a Copy" and opening the local file in the
standalone Acrobat Reader.  The search then produces the expected relevant hits
in the expected amount of processing time.

Comment 4

14 years ago
Same problem in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030601 Mozilla Firebird/0.6

I think this is for all windows versions and apparently not only for Mozilla
Suite but also Mozilla Firebird.
*** Bug 208580 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
This continues a problem in 1.4 final:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Acrobat 6.0 seems to print fine as IE 5.5 plugin.
Acrobat 5.0x worked fine in Mozilla, but Acrobat 6 requires uninstall of 5.

Comment 7

14 years ago
FWIW I'm using Acrobat 6.0 Pro.

Comment 8

14 years ago
This bug is erratic. I've printed two PDFs from Mozilla today.

Comment 9

14 years ago
It still doesn't work here. Using Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.5a) Gecko/20030712 Mozilla Firebird/0.6 and Acrobat 6.0 Professional
(which btw uses exactly the same plugin dll as the Reader). Sounds like a bug in
Acrobat to me.

Comment 10

14 years ago
It may be a bug in Acrobat, BUT Acrobat works in IE, and Acrobat is tailored to
work seamelessly with MS Office suite and other MS programs (none of which I
use, but which most potential Mozilla users use). So there probably is a way to
make Mozilla work with Acrobat, and it is important that it do so. Severity is
major.

Comment 11

14 years ago
Acrobat in IE (and in all other MS Office applications) uses an ActiveX control,
not a netscape-style plugin. Just because the ActiveX control works, and the
netscape plugin doesn't, does not necessarily make it a Mozilla bug.

Comment 12

14 years ago
The point was that Adobe is quite interested in having Acrobat work with MS
products, and they may not be particularly motivated to fix Acrobat to
accommodate Mozilla. If Mozilla works some of the time with Acrobat plugin, then
there is probably a way to make it work reliably, even if the 'bug' is in Acrobat.

There are several bugs in Acrobat 6 that do not relate to Mozilla plugin issues,
but it will be months before anything gets fixed, and then not everything will
have high priority. Since Acrobat reader is so widely used, Mozilla will feel
the heat on this plugin more than Adobe.
I am not sure how this relates to the original complaint unless that page causes
a redirect, but what I see is that with the Adobe Reader 6.0 plugin you cannot
print pdf files from an SSL server (https).  seems to work just fine with http.
 The original URL provided with the bug no longer seems to work so I can't go
there to see if I get redirected to an SSL site to load the pdf.

This would make sense as there have previously been issues with acrobat and
netscape 4 related to SSL sites.

I can also verify that this problem also occurs with the 0820 nightly build of
MozillaFirebird.

Comment 14

14 years ago
Another site which shows this problem is http://bmj.com/current.shtml
OK.  I remember more about the previous issue we had had with some older version
of Acrobat and Netscape 4.  The issue had to do with caching.  If the pdf file
was loaded to the memory rather than the disk cache it could not be printed. 
This smells a lot like a similar issue.  That would kind of explain small pdf's
don't print, big ones do as well as encrypted ones don't.

Besides printing this additionally effects at least seraching and saving the
file to disk.

Anyway, I disabled the plug-in and am just viewing PDFs in another window now.
(Reporter)

Comment 16

14 years ago
Unfortunatley, the URL I originally provided for an example PDF has been having
longterm DNS problems.  The page can be temporarily found at <a
href="http://www2.us.elsevierhealth.com/scripts/om.dll/serve?action=get-media&id=as0749806303006327&trueID=pdf_s0749806303006327&location=jar03196&type=pdf&name=x.pdf">this
site</a>.  Also, I can confirm that the URL provided in <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=207417#c14">comment #14</a>
causes the same errors for me as the original URL.

I have noticed that I have had printing errors in general (not just Acrobat)
related to <a href="http://bugzilla.mozilla.org/show_bug.cgi?id=204374">bug
204374</a>.  However, the workaround provided in that bug's <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=204374#c147">comment #147</a>,
while it has helped for that bug, has not helped for this bug.  Recently, a
temporary fixed was checked in to the 1.5 branch for that bug, but I have not
tried it out.  Though I doubt that this is the cause of the PDF problems, are
others still experiencing this PDF bug using the latest nightlies?
(Reporter)

Comment 17

14 years ago
Please excuse the clutter in my last comment.  Pure bugzilla ignorance on my
part.  My apologies for this extra (cleaned up) comment:

Unfortunatley, the URL I originally provided for an example PDF has been having
longterm DNS problems.  The page can be temporarily found at
http://www2.us.elsevierhealth.com/scripts/om.dll/serve?action=get-media&id=as0749806303006327&trueID=pdf_s0749806303006327&location=jar03196&type=pdf&name=x.pdf
Also, I can confirm that the URL provided in comment #14 causes the same errors
for me as the original URL.

I have noticed that I have had printing errors in general (not just Acrobat)
related to bug 204374.  However, the workaround provided in that bug's comment
number 147, while it has helped for that bug, has not helped for this bug. 
Recently, a temporary fixed was checked in to the 1.5 branch for that bug, but I
have not tried it out.  Though I doubt that this is the cause of the PDF
problems, are others still experiencing this PDF bug using the latest nightlies?
Well, further testing has shown that this is NOT really a printing problem.  It
is a plug-in interface problem to the new Adobe Reader plug-in.  It is not just
printing that is broken.  Basically all functions that require Adobe Reader to
be able to access the original file seem to fail.  Printing, searching within
the document, etc.

So a printing fix will NOT correct this issue.

My guess is that everyone else wo ran into this problem has done the same thing
I did and gone back to Acrobat version 5.1. :-(

Comment 19

14 years ago
*** Bug 212655 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
Here is another test case from the bug I just dupped.

ftp://www6.software.ibm.com/software/developer/library/l-datavis.pdf

I assume the problem here is with using Mozilla Print, rather than printing via
the Adobe plug-in print button?
OS: Windows ME → Windows 2000

Comment 21

14 years ago
I found one that prints correctly.  I don't know if it has something to do with
being in an iframe or not.

http://www.sans.org/rr/special/isp_blocking.php

My Env:
  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827
  Windows XP SP1 - IBM ThinkPad R32 / 1.6Ghz / 1GB / 20GB / 1280x1024
  Acrobat Reader 6.0 (Version 6.0.0 5/19/2003)
Re; Comment #20 you assume wrong.  The problem IS that you cannot print using
the Adobe plug-in print button.  Also you cannot search fro text within the
document using the adobe plug-in search (binnocular) button.  This is a plug-in
issue, NOT a printing issue.

Comment 23

14 years ago
It seems to have escaped meniton that email attachments do not print. Printing
documents from websites is variable, but attachments are consistent.

Comment 24

14 years ago
*** Bug 218688 has been marked as a duplicate of this bug. ***

Comment 25

14 years ago
I see this problem as well, but there is a twist:  printing to Postscript
printers seems to work fine, I only have a problem printing to non-postscript
printers (PCL specifically).  I can see this by printing the same document to
the same printer using two different drivers.  The wierd thing that is different
for me, is that this has happened with both Acrobat 5.1 and 6.0, and this
problem existed with NS7.02 (Moz 1.02) and Mozilla 1.3, 1.4.  Opening the
document outside of the browser in a stand-alone window of Acrobat (either 5.1
or 6.0) prints fine to the PCL printers.  I don't know if I should mention it
here or make a new bug, but even when I set "don't open in browser" in Acrobat,
Mozilla still opens the PDF using the plugin, and I have no idea where to remove
the plugin (deleting all of the files in the program plugins folder, it still
opens in a window!).  Sometimes when the planets align, the PDF will open in a
stand-alone window (usually the second time I open a PDF, but not always, and
never the first time).

Comment 26

14 years ago
*** Bug 223054 has been marked as a duplicate of this bug. ***

Comment 27

14 years ago
Mozilla 1.4 does not open pdf files with adobe reader 6 installed on NT4

Comment 28

14 years ago
Created attachment 137047 [details]
screen capture of what print preview shows

this is a capture of print preview.  the pdf document loads fine in Mozilla. 
clicking on the adobi print button looks like printing but does nothing. 
clicking on mozilla print works okay. even small dovument preview shows but
nothing prints. doing a full print preview shows that the document is blank as
per the attachment

Comment 29

14 years ago
Mozilla 2003120709.  Full Adobe acrobat 6.0.  The pdf document loads fine in
Mozilla pdf plugin.  After clicking on the adobe print button it looks like it
is printing but does nothing.  Clicking on mozilla print appears to work
properly. even small document preview shows but nothing prints. Doing a full
print preview shows that the document is blank as per the attachment (a capture
of print preview..).  If pdf file is saved then loaded into Acrobat outside of
mozilla the printing works fine.  A very long work around

Comment 30

14 years ago
Additional comment 28 and 29 or the same.  Sorry I did not know the attachment
would also show the comment

Comment 31

14 years ago
One work-around is not to use the Acrobat plug-in within Mozilla, but rather to
open the document in Acrobat outside of the browser.  You can do this by
deleting or renaming all instances of files nppdf32.dll. Doing this will remove
the plug-in automatically in Mozilla once you close and reopen it.  This seems
to work well on most machines, but in some IE freezes or shows a blank screen
when opening a pdf file from within IE.  Thus you may want to keep a copy of the
old file around in case deleting it causes IE major problema that you can't deal
with.  I have never been able to get Acrobat to open outside the browser by
configuring it (Preferences/Internet) in the Acrobat configuration settings. 
Look at http://plugindoc.mozdev.org/faqs/acroread.html for a good explanation of
this.

Comment 32

14 years ago
FYI: The update to Acrobat 6.0.1 (Only for Professional, the reader does not
have this patch) has not changed anything from the side of Adobe. The plugin
still has the same version.

Comment 33

13 years ago
I see that 6.01 of the Acrobat Reader plugin has been released. Does this new
version have the same problem?

Comment 34

13 years ago
Yes, the problem is still there. For the Reader, the plugin (nppdf32.dll) is
also not updated, the version is still 6.0.0.878

Comment 35

13 years ago
So is the only workaround to go back to an older Acrobat?  This is really a pain.

Comment 36

13 years ago
It appears to me that this is a problem to be fixed by Adobe. Their latest
release (6.0.1) fixes the problem with slow closing of windows, but it didn't
change the actual plug-in, and it doesn't seem to have fixed the printing problem.

Comment 37

13 years ago
Re: "It appears to me that this is a problem to be fixed by Adobe."

Maybe it is, or maybe it is not Adobe's concern. How long should we wait to see?
See: Additional Comment #12

It might be worth some effort, if there is any chance that Mozilla folks can
create a fix for it.

The problem seems to be worse in Mozilla 1.6b (W2K 20031208), as I've been
having a lot of crashes after viewing PDF files.

Comment 38

13 years ago
Paul's workaround in comment #31 worked fine for me.  It doesn't seem to take
that much longer to open the  program than to load the plugin.

Comment 39

13 years ago
The workaround may work. I could try it, but then I would not be beta-testing
this any more. So is this how to close the bug? Then, would Mozilla incorporate
an automatic and manual (i.e. repeatable whenever Acrobat is re-installed)
search-and-delete function, or would it pop up an alert to tell all users who
have not read this bug report what to do?

Comment 40

13 years ago
A better workaround than Comment #31, except for the few people who need Acrobat
6's new features, is to remove 6 and re-install 5.0.5. But that does not close
this bug.
Actually which workaround is better kind of depends.  If you need version 6
features to access a document, then isntalling verion 5 obviously does not work,
but if you need to access webpages with Acrobat embedded in the page then the
plug-in is the only option.

Comment 42

13 years ago
An additional problem: I tried to bypass the opening of the file in the Acrobat
plugin (which is slow and tends to cause crashes). In the context menu (right
click) I chose "Save link target as..." and tried to save. The status window says:

"Status: 58KB of ??KB (at 30.8KB/sec)
"Time Left: Unknown
"Time Elapsed: 00.02
"Progress:           "

It never completes the download, and the window never closes.
Acrobat cannot open the file. Either with status window open, it says file is in
use, or with window "Cancel"ed, it reports file as damaged. The saved file is
60KB, and when I view the file in the plugin before saving, the file is 60KB,
and can be opened.

Comment 43

13 years ago
I'm experiencing the same problem with Firefox 0.8.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Using Adobe Acrobat 6.0 Professional
Re; Comment #34, I was fooled by this comment into not trying version 6.0.1 for
myself.  I previously had this issue myself, and could also duplicate the issue
noted by the original reporter.  This issue also happend on almost every PDF
file from SSL sites.

I can not duplicate any of these issues using Mozilla Firefox veriosn 0.8 and
Adobe reader version 6.0.1.

Yes the plugin is the same, but that does not mean the problem is not fixed. 
The plugin is merely an interface betwen the browser and the reader.  The
problem could have existed and be corrected int he reader code.  Unless someone
can come up with a new testcase that actually fails with the version 6.0.1
reader, I think this bug should be closed as invalid.

Comment 45

13 years ago
Another angle: drag-and-drop of email attachment onto Acrobat desktop icon does
open Acrobat, but with this alert:
"There was an error opening this document. This file cannot be found."
Drag-and-drop into the open Acrobat 6.0 application DOES display the file.

This bug has not been getting any attention, AFAICT, but it is important, and
should not be neglected. I use IE only when necessary, and Mozilla forces me to
use IE for PDFs. I often will copy a link and use IE to open the web page (or
use Acrobat directly). IE respects the preferences I've set up in Acrobat and
opens the documents in Acrobat itself, NOT in the plugin.

(Windows 2000 Pro, SP4) Mozilla 1.7b 2004031616

Updated

13 years ago
Flags: blocking1.7+

Comment 46

13 years ago
only drivers can set blocking flags.  you can request (?) them.
Flags: blocking1.7+

Updated

13 years ago
Flags: blocking1.7?

Updated

13 years ago
Flags: blocking1.7? → blocking1.7-
As far as I can determine, the original problem reported in this bug has been
corrected in the lastest Adobe reader.  This bug should be closed a s INVALID
since it was an Acrobabt Reader bug and not a Firefox bug in the firstpalce.

Comment 48

13 years ago
Has anyone tried printing using a recent build? Today, to my surprise, I could
print a very large PDF (http://www.redbooks.ibm.com/redbooks/pdfs/sg244632.pdf
more than 20 MB) without any problem. The (tiny) one from the URL in this bug
also prints fine.

Build ID: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2)
Gecko/20040601 Firefox/0.8.0+ (BlueFyre)

I'd like to hear from others if they can print (using Mozilla builds from the
1.7 branch, Firefox builds from the 0.9 branch, and trunk users). If so, we
should probably mark this bug fixed, it's been bugging us for a very long time.

Comment 49

13 years ago
Printing wasn't a problem for me with Acrobat Reader 6.0, Moz 1.7RC2, on WinXP
Pro, but I still have the problem that: as soon as I close the tab with Acrobat,
Mozilla eats all the CPU time, which I think keeps Acrobat from being able to
close.  Killing Acrobat process in the task manager recovers Mozilla eventually
(until the next time I use PDFs)  Long time bug, reported LOTS of places, and I
think all related to a tight loop in Moz that keeps plugin process from being
able to close down (or open or print in some cases?) With very fast processors
there may be enough spare CPU to break thru this deadlock, so developers have a
hard time seeing it?  REAL problem of course it Windoze lack of true
multitasking ;-)
*** Bug 249057 has been marked as a duplicate of this bug. ***

Comment 51

13 years ago
(In reply to comment #13)
> what I see is that with the Adobe Reader 6.0 plugin you cannot print pdf files
from an SSL server (https).seems to work just fine with http.<
For both 2000 and XP using Firefox 0.9.1 with Adobe Reader 6.0.2
Holy Cow...I've had this problem with Adobe Reader, SSL, and Firefox for weeks
now! By accident after updating my apps, I just found the solution...
1. go to the SSL page in question
2. try to print
3. see the little white square with the red X next to the "secured" icon in the
lower left hand side of the browser window? 
4. Double Click the red X and choose to disable the pop-up blocker for that page!
5. Boom! Now you can view the page and print it! 
Whew! So it wasn't a bug in either Firefox or Adobe Reader...just the pop-up
blocker!

Comment 52

13 years ago
Hi Folks,
Is this bug, 254721, a duplicate of 207417 ?

Our users are experiencing problems with vn0.9.2 and vn0.9.3, not sending PDFs
to the printers. They are using Acrobat 6.0 on W2000 and WXP.

No problem with vn0.8.
--Robbie.

Comment 53

13 years ago
*** Bug 254721 has been marked as a duplicate of this bug. ***

Comment 54

13 years ago
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040830
Firefox/0.9.1+

Acrobat Reader 6.0.2

Comment 55

13 years ago
Works for me here - Firefox 0.10 with Win XP Home, Acrobat 6.0.2 Pro

Does not work for my dad - Firefox 1.0PR with Win XP Pro, Acrobat 6.0.2 Pro

Same as described - file appears to print correctly, but nothing comes from printer

Comment 56

12 years ago
Win2000SP4, Mozilla 1.7.3, Adobe Reader 6.0

PDF files did not print from within adobe reader plugin mozilla window

INSTALLED ADOBE READER 7.0 -> PROBLEM SOLVED

My advice: install reader 7.0

Comment 57

12 years ago
So, the fix is to upgrade Acrobat Reader. Does that make this bug WFM?

Comment 58

12 years ago
Oppps, didn't notice the reporters platform until I hit the Commit button.

I have heard reports that Acrobat Reader v7 doesn't support Win 9x.

Comment 59

12 years ago
and V6 does not work on Win NT 4.0  (I got about six customers left with 
NT 4).  I have to use V 5.05 on them.
QA Contact: bmartin → plugins

Updated

7 years ago
Component: Plug-ins → PDF (Adobe)
Flags: blocking1.7-
Product: Core → Plugins
QA Contact: plugins → adobe-reader
Version: Trunk → unspecified

Comment 60

4 years ago
(In reply to Todd from comment #59)
> and V6 does not work on Win NT 4.0  (I got about six customers left with 
> NT 4).  I have to use V 5.05 on them.

(In reply to David G King from comment #58)
> Oppps, didn't notice the reporters platform until I hit the Commit button.
> 
> I have heard reports that Acrobat Reader v7 doesn't support Win 9x.

(In reply to David G King from comment #57)
> So, the fix is to upgrade Acrobat Reader. Does that make this bug WFM?

(In reply to Hubert Oseguera from comment #56)
> Win2000SP4, Mozilla 1.7.3, Adobe Reader 6.0
> 
> PDF files did not print from within adobe reader plugin mozilla window
> 
> INSTALLED ADOBE READER 7.0 -> PROBLEM SOLVED
> 
> My advice: install reader 7.0

(In reply to David G King from comment #57)
> So, the fix is to upgrade Acrobat Reader. Does that make this bug WFM?

(In reply to Hubert Oseguera from comment #56)
> Win2000SP4, Mozilla 1.7.3, Adobe Reader 6.0
> 
> PDF files did not print from within adobe reader plugin mozilla window
> 
> INSTALLED ADOBE READER 7.0 -> PROBLEM SOLVED
> 
> My advice: install reader 7.0

(In reply to David G King from comment #58)
> Oppps, didn't notice the reporters platform until I hit the Commit button.
> 
> I have heard reports that Acrobat Reader v7 doesn't support Win 9x.

(In reply to Robert Stewart from comment #52)
> Hi Folks,
> Is this bug, 254721, a duplicate of 207417 ?
> 
> Our users are experiencing problems with vn0.9.2 and vn0.9.3, not sending
> PDFs
> to the printers. They are using Acrobat 6.0 on W2000 and WXP.
> 
> No problem with vn0.8.
> --Robbie.

(In reply to Todd from comment #59)
> and V6 does not work on Win NT 4.0  (I got about six customers left with 
> NT 4).  I have to use V 5.05 on them.

(In reply to David G King from comment #58)
> Oppps, didn't notice the reporters platform until I hit the Commit button.
> 
> I have heard reports that Acrobat Reader v7 doesn't support Win 9x.

(In reply to David G King from comment #57)
> So, the fix is to upgrade Acrobat Reader. Does that make this bug WFM?

Comment 61

3 years ago
I think we can close this. Adobe Reader 11 is the current version, older versions are no longer supported. Same for Win2000 etc.
[closeme]

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.