problem with javascript and .wav files ?

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: cirlimpacco, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; it-IT; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; it-IT; rv:1.4b) Gecko/20030507

when I load for the first time the page at
http://www.freeroller.net/page/ceperez/20021213#why_i_don_t_like mozilla opens a
new empty window and then a dialog asking which application should open the
"manage03.wav". this file is referenced in a javascript in the page source.
if I click "cancel" on the dialog then mozilla does nothing. the new emtpy
browser window remain there, and I have to close it manually. If I try to load
again the page then mozilla seems to remember I have clicked "cancel" previously
and just load the page. 

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.
and what's the bug ?
The .wav plays on my system because i have a plugin that handles .wav 
(in my case quicktime)
(Reporter)

Comment 2

16 years ago
the bug is that mozilla should not open an emtpy window: there's no reason to do
so and confuses the user.
and I also have some doubts about the handling of the javascript code: it seems
that the script tries to pre-load the wav files, not to play them immediately,
so I think that mozilla should not ask the user about the program to use to play
.wav files until it is really necessary. under ie6 the wav is played only when
the mouse is positioned on a certain image. if the user doesn't move the mouse
pointer onto that image them i think mozilla should stay quiet and don't bother
the user.
and I have notes that mozilla doesn't render a part of the page: the left frame
is completely missing, instead I see a white emtpy space.

Comment 3

15 years ago
Hi Michele, are you still experiencing the problem with .wav files in recent
Mozilla builds? I went to the site you linked, and it doesn't open any kind of
window. I can't tell if a wav file is playing as this machine has no sound card,
I can take another look later. Thanks for any additional information.

Comment 4

15 years ago
Resolving WFM, it's been over 5 months without a response and I cannot reproduce
the bug as described. If it is still affecting you in recent builds, please feel
free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.