If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Java (j2sdk 1.4.1) plugin does not work with Mozilla 1.4b.

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
major
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: ivo, Assigned: Joshua Xia)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509

I downloaded j2sdk-1_4_1_01-fcs-linux-i586.rpm and installed it as well, but
Mozilla 1.4b unable to run any Java applets (or even show if there is any Java
support available with "about:plugins").



Reproducible: Always

Steps to Reproduce:
1. Upgrade Mozilla 1.2.1 to Mozilla 1.4b;
2. Configure Java support;
3. Run Mozilla and point it to some Java applet;

Actual Results:  
Nothing - Java applet will not be runned.

Expected Results:  
Java applet running...

With the same Java Mozilla 1.2.1 was working fine and Konqueror is still running
it just fine.
[IS@sarmax plugin]$ ls -la j2sdk-1_4_1_01-fcs-linux-i586.rpm
-rw-r--r--    1 IS       IS       40980208 Nov 28 12:25
j2sdk-1_4_1_01-fcs-linux-i586.rpm

[IS@sarmax plugin]$ cd /usr/lib/mozilla-1.4b/plugins/
[IS@sarmax plugins]$ ls -la
total 32
drwxr-xr-x    2 root     root         4096 May 28 13:52 .
drwxr-xr-x    9 root     root         4096 May 28 12:49 ..
lrwxrwxrwx    1 root     root           46 May 28 12:54 flashplayer.xpt ->
/usr/lib/mozilla-1.0.1/plugins/flashplayer.xpt
lrwxrwxrwx    1 root     root           48 May 28 12:54 libflashplayer.so ->
/usr/lib/mozilla-1.0.1/plugins/libflashplayer.so
lrwxrwxrwx    1 root     root           66 May 28 13:52 libjavaplugin_oji.so ->
/usr/java/j2sdk1.4.1_01/jre/plugin/i386/ns610/libjavaplugin_oji.so
-rwxr-xr-x    1 root     root        18660 May  9 20:30 libnullplugin.so
[IS@sarmax plugins]$
Do you have a gcc3.2 compiled Mozilla build ? (see about:buildconfig)
if yes : do you have a gcc3.2 compiled JRE ?

Do you read the plugindoc FAQ (see the second link in about:plugins) ?
Assignee: peterlubczynski → joshua.xia
Component: Plug-ins → OJI
QA Contact: bmartin → dsirnapalli
(Reporter)

Comment 2

15 years ago
--------------
about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.2.3 20030422 (Red Hat Linux 3.2.3-4) 	-Wall -W -Wno-unused
-Wpointer-arith -Wcast-align -pedantic -Wno-long-long -pthread -pipe
c++ 	gcc version 3.2.3 20030422 (Red Hat Linux 3.2.3-4) 	-fno-rtti
-fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -pedantic -Wno-long-long
-fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--prefix=/usr --libdir=/usr/lib --enable-optimize=-O2 --disable-debug
--with-default-mozilla-five-home=/usr/lib/mozilla-1.4b --enable-strip-libs
--disable-tests --disable-short-wchar --enable-nspr-autoconf
--enable-extensions=default,irc --without-mng --enable-crypto --disable-xprint
--without-system-nspr --with-system-zlib --enable-default-toolkit=gtk2
--disable-freetype2 --enable-xft --mandir=/usr/share/man
---------------
From where do I get a gcc3.2 compiled JRE?
Does the SUN distribute it?
I see nothing gcc 3.2 specific in http://plugindoc.mozdev.org/.
and what's with http://plugindoc.mozdev.org/whichjava.html ?


Comment 4

15 years ago
I'm experiencing same. 
plugins]# ls
flashplayer.xpt  libflashplayer.so  libnullplugin.so
-------not there yet
[root@localhost plugins]# ln -s
/usr/java/j2sdk1.4.1_03/jre/plugin/i386/ns610/libjavaplugin_oji.so
/usr/lib/mozilla/plugins/
[root@localhost plugins]# ls
flashplayer.xpt  libflashplayer.so  libjavaplugin_oji.so  libnullplugin.so
-------now it is
but each time I go to load an applet on moz1.3 /rh9 / j2sdk1.4.1_03 it comes
back saying the plugin is required. The about:plugins doesn't recognize the jre.
So, this talk about gcc 3.2? I'm using java binaries, i'm not compiling. I
installed rh9 over the existing mozilla. Could that be it? Wait for moz1.4?

dgd
from the Release notes : 
"The RPMS for Red Hat 8.x are compiled with GCC 3.2"
(Reporter)

Comment 6

15 years ago
GCC 3.2 compiled Java is indeed working, but how come 1.4beta release notes are
not talking about this little issue about "GCC 3.2 vs. Java"?
because official builds are compiled with gcc2.95
(the RPMs are contributed)

-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.