iefp.pt - invalid ASP/HTML suppresses frameset from rendering

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Portuguese
P3
normal
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: joakim_46, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

This page is not rendered correctly when using Mozilla Firebird.

Reproducible: Always

Steps to Reproduce:
1. Run Mozilla Firebird
2. Load http://www.iefp.pt:8081/IEFP/index.htm


Actual Results:  
The page renders incorrectly.

Expected Results:  
The page should render correctly.

Comment 1

15 years ago
The HTML and ASP code is malformed and invalid.

IE treats <% %> as an HTML comment.

If it is NOT treated as a comment (per spec; this is what Mozilla does) then
it's text.  Which means that it implies <html> and <body> elements.

And once you have a <body>, you are not a frameset document, so subsequent
<frameset> tags must be ignored.

->TE
Assignee: blaker → nitot
Component: General → Europe: West
Priority: -- → P3
Product: Phoenix → Tech Evangelism
QA Contact: asa → brantgurganus2001
Summary: Page renders incorrectly → iefp.pt - invalid ASP/HTML suppresses frameset from rendering

Comment 2

15 years ago
-> pt
Assignee: nitot → portuguese
Component: Europe: West → Portuguese
QA Contact: brantgurganus2001 → portuguese

Comment 3

15 years ago
Created attachment 141690 [details]
Email sent to Novabase

GE Capital IT Solutions, SA was bought by Novabase so I tried to contact them
for a bug fix, attached the e-mail I sent (note: removed the From Header)

Will post new comment if/when I get a reply from them.

Comment 4

15 years ago
Created attachment 141805 [details]
Reply from Novabase

Well I got this reply.

To sum it up, I think he got the idea I was a Mozilla Zealot, He will contact
the IEFP website suggesting an intervention for am improvement.

So hopefully it will be fixed eventually.
Works for me
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.