element (fixed positioned) under iframe is still visible over iframe after setting iframe.style.display='none' and then 'block' again

RESOLVED WORKSFORME

Status

()

Core
DOM: CSS Object Model
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: jan molic, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Opera/7.11 (Linux 2.4.20-gentoo-r2 i686; U)  [en]
Build Identifier: Mozilla/5.0

just visit 
http://www.1984.cz/bug/mozilla.php

Reproducible: Always

Steps to Reproduce:
1. create DIV with position:fixed
2. create IFRAME with display:none above the DIV
3. by JavaScript do IFRAME.style.display='block' >> div will be still there over 
iframe
4. if you change DIV to position:absolute, everything works

Comment 1

15 years ago
worksforme with linux turnk 20030528
what build are you using?  see about:mozilla

Comment 2

15 years ago
WFM, 2003-05-28-08 trunk Win98.
WFM, 2003-05-28-08 trunk Linux.
(Reporter)

Comment 3

15 years ago
My build is 20030510 it is possible the bug has been fixed,
I haven't seen any reports in bugzilla before.
So I'm compiling now...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 4

15 years ago
Wrong resolution, a bug is FIXED when an error was identified in the source code
and a change was checked in to correct it.
See http://bugzilla.mozilla.org/bug_status.html

You can get freshly built trunk builds from here:
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/

It's better if you use those builds when you are reporting bugs (since they are
built from a known version of the source).
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 5

15 years ago
--> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.