Reloading off-site OBJECT inserts offsite favicon in Firefox tab

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
trivial
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Bill Mason, Assigned: Blake Ross)

Tracking

unspecified
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030527 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030527 Mozilla Firebird/0.6

Given a page that uses the OBJECT tag to load a page from another domain into
it, if you reload the inserted OBJECT page, the Firebird tab has its icon with
the favicon of the inserted OBJECT page.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.accessibleinter.net/ in a new tab.
2. Right-click on the "Web Standards Meetup Stats" box, choose This Frame ->
Reload Frame

Actual Results:  
The icon in the Firebird tag was replaced with the favicon from the domain
linked in the box via <OBJECT> (meetup.com).

Expected Results:  
The favicon (or lack of any designated favicon) should have been maintained in
the tab.

This functions correctly in Mozilla build 2003052808.

Minimal testcase to follow in case I drop the OBJECT from my page one day.
(Reporter)

Comment 1

15 years ago
Created attachment 124425 [details]
Minimized testcase

Updated

15 years ago
Blocks: 216062

Updated

15 years ago
QA Contact: asa

Updated

15 years ago
Blocks: 222104

Comment 2

15 years ago
This sounds a lot like bug 109672.
Summary: Reloading off-site OBJECT inserts offsite favicon in Firebird tab → Reloading off-site OBJECT inserts offsite favicon in Firebird tab
(Reporter)

Comment 3

15 years ago
Except I can't replicate 109672 in Mozilla or Firebird.  This bug still
replicates in Firebird but not Mozilla.

Comment 4

15 years ago
Confirmed. I see this on

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040331
Firefox/0.8.0+
Microsoft Windows 2000 Professional 5.00.2195 SP4

Updated

14 years ago
Flags: blocking1.0?
-ing will take patch
Flags: blocking1.0? → blocking1.0-
(Reporter)

Comment 6

14 years ago
Removing URL since I don't keep an OBJECT on that page anymore.  The testcase
stands in lieu.
(Reporter)

Comment 7

14 years ago
*** Bug 252160 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
I don't know if this is related, but it seems likely.
We recently put Google ads on our site, and now the tab icon becomes a Google
icon after the page loads.
http://forums.shareconnector.com/

Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Comment 9

14 years ago
The testcase is WFM with Firefox 1.0 and this nightly build, both on Linux:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20041216 Firefox/1.0+
Component: General → Tabbed Browser
Summary: Reloading off-site OBJECT inserts offsite favicon in Firebird tab → Reloading off-site OBJECT inserts offsite favicon in Firefox tab
(Reporter)

Comment 10

14 years ago
(In reply to comment #9)
> The testcase is WFM with Firefox 1.0 and this nightly build, both on Linux:
> 
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20041216 Firefox/1.0+

Still not working on 1.0 and trunk 20041215 PC/WinXP.
I'm not sure this has ever been a Linux bug.
WFM in Windows trunk, 2.0a3, and 1.5.0.4, and only fails in 1.0.8, so it apparently was fixed somewhere in the 1.8.0 era.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
QA Contact: tabbed.browser
You need to log in before you can comment on or make changes to this bug.