[PP] The Font FACE attribute is case-sensitive

VERIFIED FIXED

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Chris Petersen, Assigned: Pierre Saslawsky)

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Build: Apprunner
Version: 1999120308
Platform: Mac 8.6
Other Platforms: Works on Win 98 and Linux Redhat 6.0

Expected Results:The FACE attribute should be case-insensitive. As long as the
font name is spelled correctly and is present, the text should rendered
in the assigned font face.

What I got: The font face is only applied if the first character is in "caps"
Like Face="Chicago" not  Face="chicago".


Steps to reproduce:

1) Open the following url in Apprunner: http://slip/projects/marvin/simple/
font_face_problem.html

2) Both of these sentences are using the FACE attribute assigned "helvetica"

3) The first sentence uses the lowercase "h" and the second sentence uses the
uppercase "H".

4) The first sentence is not rendered in helvetica.
(Reporter)

Comment 1

19 years ago
I forgot to mention this test case works fine on Mac Comm 4.7, so it appears to
be a problem with Mac Apprunner.

Updated

19 years ago
Assignee: rickg → pierre

Comment 2

19 years ago
Pierre, perhaps you can take a quick look, since font resolution is a style
issue.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

19 years ago
Fixed in nsDeviceContextMac.cpp
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

19 years ago
Fixed in the Dec 8th Mac build (1999120808).
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.