applet appears offset to the right when there's no sidebar

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Luc, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

If you load the page and reduce the width of the browser window, the applet will
move all the way to the left when the sidebar is visible, but not when it is
hidden.  In a fixed size window (without any decoration) where it is normally
loaded there is also no sidebar, so the applet doesn't line up with the left
side of the window.

In Mozilla 1.3, using the same settings/Plug-in, the behaviour is correct.

Reproducible: Always

Steps to Reproduce:
1. http://www.rolandgarros.com/en_FR/index.html
2. Click on "Launch the IBM REAL-TIME SCOREBOARD" near the top left of the page
3. A fixed-size window appears, but the applet within it is shifted to the right.
The other URL I gave shows the same problem within a 'normal' window when you
hide the sidebar and reduce the width of the browser.
Actual Results:  
Part of the applet is hidden behind the right hand edge of the window and
there's a black column at the left hand side.

Expected Results:  
The applet is exactly the same size as the window and it should cover it completely.

I use the following Java Plug-in, but I don't think there's any influence:
Java(TM) Plug-in: Version 1.4.1_02
Using JRE version 1.4.1_02 Java HotSpot(TM) Client VM

Comment 1

15 years ago
Hi Luc. Are you still having problems with java applets being misplaced in
recent Mozilla builds? I tried reproducing your bug, but it seems like the
website in question has changed (at least, I could not find an IBM scoreboard
applet). Is there another site that demonstrates this, or has the problem gone
away? Any new information would be great, thank you.

Comment 2

14 years ago
Resolving invalid, the provided URL no longer works, and earlier when it did I
could not reproduce the bug. Please feel free to reopen if the bug is still
reproducable in recent builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.