mozilla uses excessive memory

RESOLVED FIXED

Status

SeaMonkey
General
--
critical
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: Patrick Galbraith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030521
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030521

mozilla is using excessive memory - this is running top...

last night:

1277 pgalbrai  15   0  410M 410M 19112 S     0.0 41.1   3:55 mozilla-bin

this morning:

2174 pgalbrai  16   0  256M 256M 18384 S    31.8 25.6   1:54 mozilla-bin

I'm not doing anything excessive with the browser, just regular pages. I can't
imagine that using 400M of memory is a normal thing for mozilla ;)

Reproducible: Always

Steps to Reproduce:
1. Use the browser
2. Shut it down when it eats up too much memory
3. Get more memory installed so the box doesn't lock up 


Actual Results:  
did the same thing after shutting it down, starting it up, and using it again.

Expected Results:  
I'm not sure what the footprint would be, but I've never seen any other version
use this much memory. I run crossover office, which even running exploder
doesn't use anywhere nearly as much ram. Getting memory kept me from lockups
because before I would end up with really bad swapping.

modern theme... nothing special.

Comment 1

15 years ago
you might be seeing bug 206561 (fixed today)
please try a nightly build from tonite or tomorrow and see if it helps.

Comment 2

15 years ago
I did some more testing, and noticed that the memory increases for each action I
take, namely loading pages. The memory footprint starts out around 38M, and
grows in 5M increments (on average) with no diminution.
(Reporter)

Comment 3

15 years ago
I got the latest build, and the problem seems to be gone. But... the build I
have is not the mozilla with the nice anti-aliased fonts. That's why I was
running the other version - the fonts were extremely pleasing. I had built that
version from an SRPMS, and I looked all over the mozilla site and could only
fine builds, not patches or source against the src that I had built. So, where
might I find this version of mizilla? It seems there are various versions all
over the place such as firebird, the stock version, and the pretty font version.
I'm confused. What is a good, centralised source of information where I can find
out these questions?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.