NULL embedded in buffer provided by necko to parser

VERIFIED DUPLICATE of bug 12415

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 12415
19 years ago
19 years ago

People

(Reporter: rickg, Assigned: rpotts (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I don't know where you guys landed on this issues, or whether or not you
even think embedded nulls are an error. Nonetheless, here's a page that
demonstrates embedded nulls being passed from necko to the parser.

Note: I've added lots of defensive code to the scanner to detect and correct
this problem, so it's not a huge issue. More of an FYI.

Comment 1

19 years ago
I thought we determined that this happened when the server sent a bad
content-length, and they were usually the last character(s) in the document. Is
this a different case? BTW, this is a dup.

Updated

19 years ago
Target Milestone: M13

Comment 2

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 12415 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Read 12415 and this is a dup of it.  Marking as VERIFIED.
You need to log in before you can comment on or make changes to this bug.