Under certain conditions a value is not submitted for a form with method=GET

RESOLVED WORKSFORME

Status

()

Core
HTML: Form Submission
--
minor
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Mitch Amiano, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

CSS style:
@media screen {  #text:before { content: "Search: " } }
Form:
<form method="GET" action="http://www.softwareadjuvant.com/cgi-bin/dummy.cgi">
<input type="text" name="text" id="text" size="20">
</form>
*Splat* Moz can't walk and chew gum at the same time. 
First, the input cursor disappears.
Next, if a default value is provided, the value erratically appears above the
input instead of inside of it.
Most importantly, Mozilla apparently loses access to the actual value of the
input field, which never gets submitted to the cgi.
If I toss out the CSS, it works, but I lose the snip of help text. If I toss out
the name, the CGI doesn't get the field. 

Reproducible: Always

Steps to Reproduce:
1. Use a form input with both name and id set. 
2. Use a CSS style in the header, with @media screen { #someid:before { content:
"stuff" } }
3. Use GET for the form action. 
4. Type something into the field. Press enter.

Actual Results:  
The url which results looks like this:
http://www.softwareadjuvant.com/cgi-bin/dummy.cgi?text=

Expected Results:  
http://www.softwareadjuvant.com/cgi-bin/dummy.cgi?text=somestuffItypedin

Well, I'm trying to put this little field up on my Wiki site, and this bug is
preventing it from working in Mozilla.  Either the users don't know what the
heck the field is for, or they have to put up with a spurious form field on the
printed output, or the thing simply doesn't work. 

It would make me sick to make the claim, "It only works in IE" (because I've
tried to make it work for standard Moz).
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

13 years ago
I'm marking this as Worksforme because the problem is no longer reproduceable in
current versions of Mozilla. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.