UI to disable Find As You Type (type-ahead find)

VERIFIED FIXED

Status

()

Firefox
Preferences
--
enhancement
VERIFIED FIXED
15 years ago
12 years ago

People

(Reporter: Andy Lyttle, Assigned: mconnor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 6 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

I personally find type-ahead find to be annoying, since accidentally pressing a
key tends to scroll unpredictably and I have to figure out where I was.  It can
be disabled, but not from the Preferences dialog.

Reproducible: Always

Steps to Reproduce:
1. Open Preferences
2. Look for a way to disable type-ahead find

Actual Results:  
There is no such option.

Expected Results:  
Perhaps it should be listed under General?  Or perhaps a new category.

Comment 1

15 years ago
-> RFE

Mozilla Firebird Help has a solution.
http://texturizer.net/firebird/tips.html#beh_taf

Don't let Mozilla Firebird bloated by mess of options.
So I suggest WONTFIX.
Severity: normal → enhancement
(Reporter)

Comment 2

15 years ago
Whoops, sorry, should have been an RFE.  Fixing subject.

My concern is that the feature may be confusing to a new user, and it's not at all obvious that the 
feature is called Find As You Type  (I didn't realize it had been renamed myself - saw the 
documentation but I guess I skipped over the introduction).  Without knowing that, it's non-trivial 
to find it in the documentation.  I agree that Preferences shouldn't become unnecessarily bloated, 
but I think this is reasonable.

Personally I would prefer that it be turned off by default, and let users turn it on - this gives them 
a chance to see what it's called, so they can read documentation about how to use it if they want.  
This is how Safari's tabbed browsing feature works, for example - it could confuse new users, so 
it's off by default with an obvious option in Preferences.  Getting it turned off by default is 
probably a losing battle though, so I won't fight it. :-)

One definition of a bug is "a feature that can't be turned off".  A feature that can't be turned off 
except by hacking JavaScript code is better, but not as good as it could be. :-)
Summary: Need UI to disable type-ahead find → [RFE] UI to disable Find As You Type (type-ahead find)

Comment 3

15 years ago
don't use RFE keyword. use enh severity
Summary: [RFE] UI to disable Find As You Type (type-ahead find) → UI to disable Find As You Type (type-ahead find)
(Assignee)

Comment 4

15 years ago
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 5

15 years ago
Created attachment 130021 [details] [diff] [review]
patch to add to advanced options

Comment 6

15 years ago
Created attachment 130022 [details]
pref-advanced.js needed for above patch

this js file should be placed next to pref-advanced.xul

Comment 7

15 years ago
Created attachment 130026 [details]
shortenfied version of pref-advanced.js
Attachment #130022 - Attachment is obsolete: true
(Assignee)

Comment 8

15 years ago
Just because six prefs exist doesn't mean they all need to have UI

Links only and on/off are all that end-users are likely to use.  The rest is
stuff more suited for hidden prefs.

Comment 9

15 years ago
Created attachment 130087 [details] [diff] [review]
patch with less options

this patch only includes UI options for on/off, text/links only, and sound
on/off.  I thought it would be good idea to keep the sound pref as i have heard
some people complaining about it.
Attachment #130021 - Attachment is obsolete: true

Comment 10

15 years ago
Created attachment 130088 [details]
new pref-advanced.js to go with new patch
Attachment #130026 - Attachment is obsolete: true
(Assignee)

Comment 11

15 years ago
Created attachment 130128 [details] [diff] [review]
patch based on will's previous patches

simpler patch, for eight lines of JS we can hold off on adding another file for
now, drop the sounds pref since its not going to bother 95% of people
Attachment #130087 - Attachment is obsolete: true
Attachment #130088 - Attachment is obsolete: true
(Assignee)

Comment 12

15 years ago
Created attachment 130131 [details] [diff] [review]
revised patch

move options to accessibility, clean up wording
(Assignee)

Updated

15 years ago
Attachment #130128 - Attachment is obsolete: true
(Assignee)

Comment 13

15 years ago
--> me
Assignee: blake → mpconnor

Comment 14

15 years ago
Comment on attachment 130131 [details] [diff] [review]
revised patch

r=noririty
Attachment #130131 - Flags: review+

Comment 15

15 years ago
fix landed
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
verified fixed 2003-11-09
Status: RESOLVED → VERIFIED
(Assignee)

Comment 17

12 years ago
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.