If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Patch] URI written in location bars doesn't persist tab/window switching

VERIFIED DUPLICATE of bug 203102

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 203102
15 years ago
6 years ago

People

(Reporter: Chris Neale, Assigned: Blake Ross)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030530 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030530 Mozilla Firebird/0.6

as for bug 104778 [Mozilla Seamonkey]

switching tabs for tabs with entered, but not yet visited URIs returns the URI
to about:blank on return to that tab

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Created attachment 124568 [details] [diff] [review]
patch based on that for bug 104778 to replicate changes in browser/
(Reporter)

Comment 2

15 years ago
there is a quirk to this patch :

if a URI is entered, and 'go not clicked'/'enter not pressed', this URI remains
in the urlbar when you switch to an existing tab, which I suppose is less of a
problem than the URI disappearing, to be replaced by about:blank

Comment 3

15 years ago
I noticed that Mozilla and Mozilla Firebird need different patches to solve this
issue.

This bug depends on but is *not* a duplicate of 104778.

-> dataloss
-> critical
-> NEW
Severity: normal → critical
Status: UNCONFIRMED → NEW
Depends on: 104778
Ever confirmed: true
Keywords: dataloss
Summary: MozillaFirebird : URI written in location bars doesn't persist tab/window switching → [Patch] URI written in location bars doesn't persist tab/window switching

Comment 4

15 years ago
We already have a bug for that: bug 203102
Please post your patch there. Thanks.

*** This bug has been marked as a duplicate of 203102 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Based on comment 4:
Moving (d.o.) 'bug 104778' to bug 203102.
No longer depends on: 104778

Comment 6

14 years ago
Mass-verifying. Sorry for bugspam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.