Times font looks distorted with SIZE=1 and Bold elements applied [FONT MAC] {ll}

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Chris Petersen, Assigned: dcone (gone))

Tracking

({fonts, pp})

Trunk
PowerPC
Mac System 8.6
fonts, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Build: Apprunner
Version: 1999120308
Platforms: Mac
Other Platforms: Windows 98 and Linu Redhat 6.0 work

Expected results:
The Times font should appear smooth and not jaggy. This test case renders
correctly in Mac Comm 4.7 and Mac IE 4.5.

What I got: The Times font looks very jaggy.

Steps to reproduce:

1) Open the test case in both Apprunner and Comm 4.7.
2) The Times font looks very jaggy in comparsion to Comm 4.7.
(Reporter)

Comment 1

18 years ago
Created attachment 3208 [details]
How the test case renders in Comm 4.7
(Reporter)

Comment 2

18 years ago
Created attachment 3209 [details]
How the test case renders in Apprunner

Updated

18 years ago
Assignee: beard → troy
Component: Compositor → Layout

Comment 3

18 years ago
Looks like an improper font selection bug. This would be either a GFX bug, or
layout's use of GFX. I'd guess layout for now. Do we have a GFX API to determine
if a font size exists?

Updated

18 years ago
Assignee: troy → dcone

Comment 4

18 years ago
It's definitely not layout. Re-asigning to Don to investigate Mac gfx issues
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M15

Updated

18 years ago
Keywords: pp
(Assignee)

Updated

18 years ago
Summary: [PP]Times font looks distorted with SIZE=1 and Bold elements applied → [FONT MAC]Times font looks distorted with SIZE=1 and Bold elements applied
Erik, are you aware of this bug?
Keywords: 4xp
Summary: [FONT MAC]Times font looks distorted with SIZE=1 and Bold elements applied → Times font looks distorted with SIZE=1 and Bold elements applied [FONT MAC] {font} {ll}

Comment 6

18 years ago
Ian, thanks for letting me know. Frank (ftang) wrote the Unicode support for the
Mac font engine.

Frank, could you take a look at this? It may have something to do with your
changes.
Summary: Times font looks distorted with SIZE=1 and Bold elements applied [FONT MAC] {font} {ll} → Times font looks distorted with SIZE=1 and Bold elements applied [FONT MAC] {ll}
Keywords: fonts
(Assignee)

Updated

18 years ago
Target Milestone: M15 → M17
(Reporter)

Comment 7

18 years ago
I'm not able to repro this problem in the May 2 build.
(Assignee)

Comment 8

18 years ago
This seems related to another smoothing bug that was fixed.  I can no longer 
reproduce this..
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.