Ability to save images in multiple file formats (at least optionally offer to save as bitmap/BMP etc.)

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
16 years ago
9 years ago

People

(Reporter: mrgeetar, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507

IE 6 has a feature where the user can "Save Image As.." and save it as either
the original file type or as a BMP.  It would be nice if Mozilla could save
images as BMPs, TIFs, PNGs, etc., formats other than the original file's format.
 We use the Internet often to find pictures for a newspaper we publish, and
sometimes JPGs we save do not import properly into Photoshop, so we are forced
to use BMPs instead.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
*** Bug 224316 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
Bug 152163 made this same suggestion before this bug report.  However, Bug
152163 only deals with bitmaps.  Would it be appropriate to mark Bug 152163 as a
duplicate considering this bug report covers more areas?

Also, I believe the following changes would be appropriate:
Hardware -> All
OS -> All
*** Bug 280576 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
I'm not sure if this is the right component: ImageLib decodes GIF, JPEG and PNG
images, and provides the decoded data to the compositor for display. See
http://www.mozilla.org/quality/browser/imaging-bug-writing.html.

Perhaps File Handling or something other fits better.
Assignee: jdunn → pavlov
OS: Windows XP → All
QA Contact: tpreston
Hardware: PC → All
Summary: Ability to save images in multiple file formats → Ability to save images in multiple file formats (at least optionally offer to save as bitmap/BMP etc.)

Comment 5

14 years ago
*** Bug 152163 has been marked as a duplicate of this bug. ***
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 7

13 years ago
I still would like to have this feature

Updated

12 years ago
Assignee: pavlov → nobody
QA Contact: imagelib

Comment 8

11 years ago
I certainly would like to see this functionality.
I don't think we want this. There are plenty of transcoding tools available, and I don't see a compelling reason for having one in the browser that justifies the additional code complexity.

Resolving WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.