Closed Bug 20774 Opened 20 years ago Closed 20 years ago

Plain text editor window does not open correctly

Categories

(Core :: Editor, defect, P3, major)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: teruko, Assigned: cmanske)

Details

(Whiteboard: can't verify until 21077 is fixed.)

When you open the Plain text editor window, the window does not display the right Plain text editor.

Steps of reproduce
1. Open Composer
2. Select menu Debug|Plaintext Editor

The window will open, but the contain of the window will be mixed up from Composer and something else.

I tested 120208 and 120315 Win32 build under Winnt 4.0J.
This does not happens under Mac and Linux.
Assignee: beppe → akkana
assigning to akkana. Akkana can you please take a look at this and reassign as
appropriate
Assignee: akkana → cmanske
Summary: [PP] Plain text editor window does not open correctly → Plain text editor window does not open correctly
XUL problem -- the editor window is coming up bigger than full screen, on both
Linux and Windows (removing PP designation) though it's worse on Windows (the
contents of the window don't draw).  Looks like a backend xul change: nothing
significant has changed in TextEditorAppShell.xul, just Hyatt's minor change to
make the editor skin-compliant.  Charley, any idea what might be happening?

The plaintext editor window worked fine on Friday, so the change happened over
the weekend.
Status: NEW → ASSIGNED
Target Milestone: M12
It's a very easy fix. I forgot about this window when making some menu changes.
The problem was the "Format" menu. It seems to me we shouldn't even have
a Format menu since this is plain text only, correct?
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Checked in 12/6
Whiteboard: can't verify until 21077 is fixed.
Now the plaintext editor doesn't even come up at all using 12/7 build.

Error: can't load
resource:///chrome/editor/content/default/TextEditorAppshell.xul

I filed a separate bug..see bug 21077...leaving this one in resolved-ixed
state..will verify after 21077 is fixed.
Status: RESOLVED → VERIFIED
verified in 12/10 build...Teruko, please reopen if its still not
fine for you...
You need to log in before you can comment on or make changes to this bug.