network.cookie.lifetime.days preference is set but has no effect.

VERIFIED INVALID

Status

()

Firefox
Preferences
--
minor
VERIFIED INVALID
15 years ago
12 years ago

People

(Reporter: Graham Yardley, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

network.cookie.lifetime.days is set to 90 by default however
network.cookie.lifetime.enabled is not there.  Creating
network.cookie.lifetime.enabled and setting it to true has no effect on cookie
lifetime.  

Reproducible: Always

Steps to Reproduce:
1. Create network.cookie.lifetime.enabled and set to true
network.cookie.enableForCurrentSessionOnly must be false
2. Got to http://www.google.com/
3. Open Options and go to Privacy/Cookies/View
4.  See the lifetime of google cookie PREF
Actual Results:  
Cookie expires on Sunday, January 17, 2038 2:13:50 PM  Your time will vary.  

Expected Results:  
September 06, 2003 9:45:50 AM

I suppose you could want to remove this feature completely, but then
network.cookie.lifetime.days should be removed from the preferences

Comment 1

15 years ago
Graham, please give the following settings a try:

network.cookie.lifetime.enabled = true (like already mentioned)
network.cookie.lifetime.behavior = 1 (<= important in order to ensure that Moz.
reads network.cookie.lifetime.days!)
network.cookie.lifetime.days = 90 

By using these preferences the cookie expires someday in September 2003, which
seems to be ok.

=> resolving WFM - please feel free to reopen bug if this doesn't work for you!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Summary: network.cookie.lifetime.days preference is set but has no effect. → network.cookie.lifetime.days preference is set but has no effect.
(Reporter)

Comment 2

15 years ago
Tested on 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla
Firebird/0.6 and nightly Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.4b) Gecko/20030603 Mozilla Firebird/0.6 in a different directory and with a
new profile.  

Note that both network.cookie.lifetime.enabled and
network.cookie.lifetime.behavior did not exist by default and had to be created
in MF while in Mozilla they exist by default.

Creating key network.cookie.lifetime.behavior as integer and setting it to 1 had
no effect. 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor
INVALID, code is not enabled for Firebird in the cookies backend.  (Probably
going to be gone completely by the time I'm done with cookies :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID

Comment 5

14 years ago
verified invalid 2004-01-10
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.