All users were logged out of Bugzilla on October 13th, 2018

Moz 1.4RC1 crashes immediately on start (quick launch, too)

VERIFIED DUPLICATE of bug 123907

Status

--
critical
VERIFIED DUPLICATE of bug 123907
16 years ago
14 years ago

People

(Reporter: felipe, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

The summary pretty much says it all; I have few stability issues with 1.3.1, but
1.4RC1 won't execute at all without crashing. This includes the quick launch
thingie; I tried a reboot, and the same thing happened.

Reproducible: Always

Steps to Reproduce:
1. Install Moz 1.4RC1 onto my Win2k box
2. Try to run (presumably) any component of it

Actual Results:  
crash

Expected Results:  
run

It said an error log was being created, but I couldn't find it (in my brief and
uninformed search).

Comment 1

16 years ago
Yup this is correct - but it's generally the case that you have installed over
the top of a previous Mozilla install. If this is the case then all you have to
to is uninstall Mozilla completely and then reinstall (probably also worth
deleting C:\Program Files\mozilla.org\)

While this fixes the problem - it's not a good fix - the reality here is that
people WILL install mozilla over the top and will not think about uninstalling
previous versions. 

I would suggest either 
a) A clean up process is added to the beginning of the Mozilla installer to
remove previous versions (but of course not any user data) (Fairly involved)
b) I dialog box appears warning the user that a previous version exists and
should be uninstalled first (easier)
Reporter:
Have you installed addons in your old build ?

If yes : install in a clean directory..
(uninstall, delete the whole mozilla application directory except the plugins
subdirectory and reinstall mozilla)

Severity: blocker → major
Keywords: crash

Updated

16 years ago
Severity: major → critical
(Reporter)

Comment 3

16 years ago
Actually, this was a "clean" install in that I did do an uninstall (via Control 
Panel) before I installed 1.4RC1. Basically, I did the same thing I've done 
with previous Mozilla upgrades (going from 1.3 to 1.3.1, for instance), and 
this is the first time I've seen this behavior.

I think I did install some add-ons in 1.3.1....when I get back home I'll 
uninstall and wipe the mozilla directory (as commentor #2 suggested), then try 
the 1.4RC1 install again.
(Reporter)

Comment 4

16 years ago
I reinstalled with cleaning out the non-"Plugins" directories, and all appears
to be fine now.

*** This bug has been marked as a duplicate of 123907 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.