crash on selecting items and choosing a product id

RESOLVED DUPLICATE of bug 203041

Status

()

--
critical
RESOLVED DUPLICATE of bug 203041
16 years ago
16 years ago

People

(Reporter: pshempel, Assigned: john)

Tracking

({crash, regression, testcase})

Trunk
crash, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Look up TB20617263X, URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030515 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030515 Mozilla Firebird/0.6

When entering into the itme edit are (after loging into
http://demo.icdevgroup.org/i/demo1/admin with demo demo) choosing items and then
slecting a product to edit causes on Mac, Power Mac, PC ALL (MS, LINUX) to crash.

This is a problem with all browsers using mozilla build from 1.3 on up. For some
reason using Phoenix 0.5 (released version on site) does not dump or crash on
LINUX, have not tested on any other platform. Phoenix 0.6, and All mozilla
builds from 1.3 are fully reproducable.


Reproducible: Always

Steps to Reproduce:
1. Login to site (demo demo)
2. Choose Items
3. Select a product to edit
4. Watch
Actual Results:  
Browser crashes.

Expected Results:  
Not crashed

Mozilla just disappears, nothing more
(Reporter)

Updated

16 years ago
OS: Linux → All
Keywords: crash

Comment 1

16 years ago
WFM with my Linux trunk build from yesterday.

Comment 2

16 years ago
confirming using Firebird 20030529 on Win2k: TB20617263X.
Assignee: general → other
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
Keywords: stackwanted
QA Contact: general → ian
Whiteboard: TB20617263X

Comment 3

16 years ago
Setting Hardware=All per comment 0.
Keywords: stackwanted
Hardware: PC → All
Whiteboard: TB20617263X → Look up TB20617263X

Comment 4

16 years ago
Created attachment 124648 [details]
stacktrace

Comment 5

16 years ago
steps to reproduce:
3.5. click "Edit checked"

Comment 6

16 years ago
Created attachment 124650 [details]
testcase

load the testcase (nothing)
reload the testcase => crash

<body onload="document.getElementById('mvpanpanel0').style.display='none';">
   <input style="position:absolute" id="mvpanpanel0" type="file">
</body>

Comment 7

16 years ago
Created attachment 124652 [details]
stacktrace from testcase (quite a bit shorter)

the stack is completely different, suggesting a different bug, but I removed
the <input type=file> tags from the original URL and it loaded fine
Attachment #124648 - Attachment is obsolete: true

Comment 8

16 years ago
==> form controls

this regressed between linux trunk 2002121908 and 2002122008, placing blame on
bug 152844
Assignee: other → jkeiser
Component: Layout → Layout: Form Controls
Keywords: regression, testcase

Comment 9

16 years ago
This crash has the same stack as bug 203041 and is caused by the same line
as mentioned in bug 203041 comment 6.

*** This bug has been marked as a duplicate of 203041 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.