If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Popup Link will not open unless page is completely loaded.

VERIFIED DUPLICATE of bug 101190

Status

()

Core
DOM: Core & HTML
VERIFIED DUPLICATE of bug 101190
15 years ago
13 years ago

People

(Reporter: bigbundas, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507

When going to some pages, clicking on a link that should call a pop-up window
will not work if you click on it before the page loads. If clicked, even after
the page loads, the link will no longer work. Only if you let the page
completely load, will the link work. This does not apply to all web pages with
pop-up links. I have yet been unable to identify why it works on some pages and
doesn't on other pages. However, if I find a page that doesn't work, it doesn't
work on any of the three computers I try it on.

Reproducible: Always

Steps to Reproduce:
1. Go to http://revistaepoca.globo.com/
2. Click on one of the images below the header before the page completely loads
3. Nothing will happen. Even if you then let the page load, you won't be able to
get those links to work.
4. Now refresh the page and let it load completely before clicking on a link.
The links should work fine now.

Actual Results:  
Links to pop-up windows did not work.

Expected Results:  
Open the pop-up windows even if the page was not completely loaded.

This is sometimes hard to duplicate if the page loads all at once, since there
is no way to click on the link before the page is completely loaded. However for
the pages that don't load like this, it is a pretty common problem I come across.

Comment 1

15 years ago
Reporter: What value you have set for dom.disable_open_during_load in about:config?
(Reporter)

Comment 2

15 years ago
I had it set to true. When I set it to false it seemed to fixed the problem,
however, at the same time I can no longer block unwanted pop-up windows. Can
both work at the same time?

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 101190 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
For me when i set this to true: The popup doesn't work during load (that's the
sense of the pref :), when loading the page has finished the popup works. So
this would still be a bug.
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.