crash upon choosing nickname if I type an IRC URL directly into the browser

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: mozilla, Assigned: rginda)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030529

I typed in an IRC URL into the browser (irc://irc.freenode.org, to be specific)
for the first time and it popped up a prompt asking for a nickname. I couldn't
type in this prompt, click okay, or click cancel. However, it was possible to
select the text before it crashed. I had to command-Q the window, it didn't
respond to command-W

Reproducible: Always

Steps to Reproduce:
1. Install Mozilla.
2. Type in an IRC URL.
3. It will prompt for a nickname and freeze.

Actual Results:  
The program freezed. I had to command-Q.

Expected Results:  
It should have allowed me to type something into the prompt, cancel, or click okay.

I am using the Modern theme. I didn't think to try it with the default Classic
theme.
(Reporter)

Comment 1

16 years ago
Okay, I tried it with different themes and different IRC servers. I got the same result. However, if I 
clicked on another application (like the Finder) and then clicked back on the window, it works.

Comment 2

16 years ago
wfm 2003053008 winXP, I get an error saying that this is not a valid URL

Comment 3

16 years ago
Andrew, if you can still use command+q to quit the application, it has neither
crashed nor frozen/hung.

WorksForMe using FizzillaMach/2003-05-29-08-trunk. Andrew, can you reproduce
this problem using another Mozilla user profile?
Severity: normal → major
(Reporter)

Comment 4

16 years ago
Sorry about reporting it as crashing, however, now I don't know what to call what happens.

When I tested it again with the different themes and IRC servers (Additional Comment 1), I had to 
first created a new profile since I had already changed my nickname from IRCMonkey and it was no 
longer prompting me for the name. So, to answer your question, it happens with other profiles.

Comment 5

15 years ago
Yet another bug that has been untouched for ages...  I take it this has been
fixed?  It appears to be a loner as no other bugs have been filed that are even
similar.

-Robin
(Reporter)

Comment 6

15 years ago
Sorry about leaving this random bug in here. I'll check it out in a little while
to see what happens with a newer build of Mozilla.

Andrew
Product: Core → Other Applications

Comment 7

14 years ago
(In reply to comment #6)
> Sorry about leaving this random bug in here. I'll check it out in a little while
> to see what happens with a newer build of Mozilla.
> 
> Andrew

Does this problem still occur on newer versions of Mozilla and Chatzilla?
(Reporter)

Comment 8

14 years ago
It seems to be fixed now. Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.