Renderer appears to ignore colspan statements

RESOLVED DUPLICATE of bug 187550

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 187550
15 years ago
15 years ago

People

(Reporter: Matt Dale, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Various

Looking at the page http://www.megla.net/techdbhome.php (and others on the 
site), the "article" table is rendering incorrectly with a large black box to 
the right. This black box is supposed to be only a few pixels wide to give a 
shadow effect around the table.
All pages conform to HTML 4.01 Transitional and CSS passes the validator (with 
minor errors, but not ones that cause it to be invallid).
I'm guessing that colspan is the problem here, as I have not tried to reproduce 
the situation here as the pages are valid so it is up to the browser to render 
it right.

I have achieved sucessful renders in several versions of IE, and had reports of 
correct rendering in Netscape and Opera from users I queried while trying to 
solve the issue.

Users with this problem are reporting that it occurs every time and that they 
never get a correct render. The versions in question are Moz 1.3 and 1.3.1.

You can find a case screenshot here http://dustdance.org/images/megla.png

Reproducible: Always

Steps to Reproduce:
1. Load the page

Actual Results:  
http://dustdance.org/images/megla.png

Expected Results:  
http://www.megla.net/render.jpg
(Reporter)

Comment 1

15 years ago
Created attachment 124670 [details]
Test case - a correct render in IE 6 SP1
(Reporter)

Comment 2

15 years ago
I have tracked down the user who gave me that screenshot of the bad render. His 
Build ID is:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

Comment 3

15 years ago
Created attachment 124674 [details]
HTML Testcase

<HTML>
<HEAD><TITLE>megla.net</TITLE></HEAD>

<BODY>
<table cellpadding=5 cellspacing=5 border=1>
  <tr>
    <td colspan=2>Welcome to techDB!</td>
    <td width=2 bgcolor="#111122"></td></tr>
  <tr>
    <td width="1%"></td>
    <td width="*" colspan=2 bgcolor="#111122"></td></tr>
</table>

</BODY></HTML>


I think the problem has something to do with the "width"-tags. If I play with
the value in <td width="1%"></td> - then it's rendert correct.

Comment 4

15 years ago
Created attachment 124678 [details]
testcase

the layout strategy does not like to give space to pseudo columns

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 187550 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

15 years ago
From looking at the one's you've marked as duplicate, this is being 
considered "correct" behaviour since there is no spec for the situation.
This is going to cause problems for me since every other browser acts in what 
I'd consider to be the correct way and allocates space.

What is the situation regarding this behaviour in 1.4?
You need to log in before you can comment on or make changes to this bug.