Rename Folder option is useless in the newsgroup

VERIFIED FIXED in mozilla1.7beta

Status

VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: pascalc, Assigned: Biesinger)

Tracking

({regression, useless-UI})

Trunk
mozilla1.7beta
regression, useless-UI
Bug Flags:
blocking1.4 -
blocking1.7b +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-aviary1.0)

Attachments

(6 obsolete attachments)

(Reporter)

Description

16 years ago
build 2003052508 WinXP

1 in MailNews right click on a newsgroup name
2 select "rename folder"

this option is useless for newsgroup which are not folder and has no effect,
Netscape 7.02 did not have this option

I think it should be removed for 1.4 on which Netcaspe will be built, this is
not a high risk change but useless UI shouldn't be shown into a commercial build
(Reporter)

Updated

16 years ago
Flags: blocking1.4?
(Reporter)

Comment 1

16 years ago
This useless option wasn't in Ns7.02, adding "regression" keyword.
Keywords: regression

Comment 2

16 years ago
I would like the "rename folder" function to be functioning. I have subscribed
some newsgroups on the support-forums.novell.com server and as the newsgroups
are organized hierarchically there, the name of the group (including the path)
is too long. As the result, I am getting abbreviated forms of the groups and I
am not able to differentiate between them.

Example: 
for newsgroup named "novell.support.os.server.netware6x.install-upgrade"
I am getting "n.s.o.s.n.install-upgrade", which is unfortunatelly identical to
the   abbreviation for the "novell.support.os.server.netware5x.install-upgrade"
newsgroup.

Updated

16 years ago
Flags: blocking1.4? → blocking1.4-
(Reporter)

Comment 3

16 years ago
Since this is not a blocker for 1.4, I add a nsbeta1 keyword. Please, do not
release a Netscape 7.1 with a new context menu option which has no effect,
disable this option until there is some working code behind it!
Keywords: nsbeta1

Comment 4

16 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Created attachment 130970 [details] [diff] [review]
Patch v.1

Stop "Rename Folder" appearing in newsgroups.

Gerv
Taking bug.

Gerv
Assignee: sspitzer → gerv
Target Milestone: --- → mozilla1.5final
Comment on attachment 130970 [details] [diff] [review]
Patch v.1

Asking Seth for review
Attachment #130970 - Flags: review?(sspitzer)
Comment on attachment 130970 [details] [diff] [review]
Patch v.1

why is the folder attribute "CanRename" true for a newsgroup?

that's unexpected, give this code:

http://lxr.mozilla.org/mozilla/source/mailnews/news/src/nsNewsFolder.cpp#473

we should find out what's going on here.

Comment 9

15 years ago
*** Bug 219998 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
I've seen some comments in here suggesting that the 'Rename Folder' context 
menu item be removed all together from the newsgroups.  I strongly disagree.  
Martin Strobl described the problem in comment #2.  I have a similar problem, 
except to a larger degree (many NGs appear identical).

It would be great, if one could assign an alias to a newsgroup - a killer 
feature for me.
(Reporter)

Comment 11

15 years ago
Then file a RFE bug to get newsgroup aliases, this is a different issue
Attachment #130970 - Flags: review?(sspitzer)

Comment 12

15 years ago
Created attachment 138330 [details] [diff] [review]
Patch almost identical to Patch v1

Comment 13

15 years ago
When will the patch finally be checked in? If you take a look at the code you
will see that somebody just forgot to add the && isMail condition in line 334 of
mailContextMenus.js because the variable isMail is set in the beginning of the
function but never used again. Ok, it is strange that canRename is true for
ngs... but why make a fool of Mozilla by keeping obviously nonsensical menuitems
that can be removed by changing one line in one file?
seth: the folder attribute isn't true. canRename becomes true because of this line:
   canRename = canRename || !isSpecialFolder;
isSpecialFolder is, of course, false.

this line was added for bug 190354.

I'm attaching a new patch that I like more than the current patch here.
Attachment #138344 - Flags: review?(sspitzer)

Updated

15 years ago
Flags: blocking1.7b?

Updated

15 years ago
Attachment #138344 - Flags: superreview+

Comment 16

15 years ago
Comment on attachment 138344 [details] [diff] [review]
patch v2

a=chofmann for 1.7b
Attachment #138344 - Flags: approval1.7b+

Updated

15 years ago
Flags: blocking1.7b? → blocking1.7b+

Comment 17

15 years ago
Comment on attachment 138344 [details] [diff] [review]
patch v2

asking Neil for the r=
Attachment #138344 - Flags: review?(sspitzer) → review?(neil.parkwaycc.co.uk)
Comment on attachment 138344 [details] [diff] [review]
patch v2

neil points out that I can just remove this line
Attachment #138344 - Flags: review?(neil.parkwaycc.co.uk) → review-
Created attachment 143992 [details] [diff] [review]
(Av3) patch v3
[Checked in: Comment 23]
Assignee: gerv → cbiesinger
Attachment #130970 - Attachment is obsolete: true
Attachment #138330 - Attachment is obsolete: true
Attachment #138344 - Attachment is obsolete: true
Status: NEW → ASSIGNED

Updated

15 years ago
Attachment #143992 - Flags: review+
Comment on attachment 143992 [details] [diff] [review]
(Av3) patch v3
[Checked in: Comment 23]

note, if you want this checked in today, I can't do it
Attachment #143992 - Flags: superreview?(mscott)
Attachment #143992 - Flags: approval1.7b?

Updated

15 years ago
Attachment #143992 - Flags: superreview?(mscott) → superreview+

Comment 21

15 years ago
Comment on attachment 143992 [details] [diff] [review]
(Av3) patch v3
[Checked in: Comment 23]

carrying over the 1.7b approval for this patch
Attachment #143992 - Flags: approval1.7b? → approval1.7b+

Comment 22

15 years ago
ShowMenuItem(...) needs to check isMail.
Comment on attachment 143992 [details] [diff] [review]
(Av3) patch v3
[Checked in: Comment 23]


Check in: { 03/17/2004 03:22	neil%parkwaycc.co.uk	mozilla/ mailnews/
base/ resources/ content/ mailContextMenus.js	     1.47 }
Attachment #143992 - Attachment description: patch v3 → (Av3) patch v3 [Checked in: Comment 23]
Attachment #143992 - Attachment is obsolete: true
(In reply to comment #22)
> ShowMenuItem(...) needs to check isMail.

Is an additional patch like
{{
- 333   ShowMenuItem("folderPaneContext-rename", (numSelected <= 1) && !isServer
&& !isSpecialFolder && canRename);

+ 333   ShowMenuItem("folderPaneContext-rename", (numSelected <= 1) && !isServer
&& (isMail && !isSpecialFolder) && canRename);
}}
needed, which would be more like |function SetupRemoveMenuItem(...)| ?

Otherwise, we should certainly remove the unused
{{
- 328   var isMail = serverType != 'nntp';
}}
(per comment 13)
OS: Windows XP → All
Hardware: PC → All
Target Milestone: mozilla1.5final → mozilla1.7beta

Comment 25

15 years ago
Ignore comment 22. (Hint: test with clean sources next time)
ok, this bug is fixed with neil's checkin. thanks for doing it for me.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Created attachment 144270 [details] [diff] [review]
(Bv1-SM) <mailContextMenus.js> (SeaMonkey part)
[Checked in: Comment 30]

Unused |var isMail| removal, per previous comments.
Attachment #144270 - Flags: review?(neil.parkwaycc.co.uk)

Updated

15 years ago
Attachment #144270 - Flags: review?(neil.parkwaycc.co.uk) → review+
Attachment #144270 - Flags: superreview?(mscott)
Attachment #144270 - Attachment description: (Bv1) <mailContextMenus.js> → (Bv1-SM) <mailContextMenus.js> (SeaMonkey part)

Updated

15 years ago
Attachment #144270 - Flags: superreview?(mscott) → superreview+
Created attachment 151842 [details] [diff] [review]
(Bv1-TB) <mailContextMenus.js> (ThunderBird part)
[Checked in: Comment 31]
Comment on attachment 151842 [details] [diff] [review]
(Bv1-TB) <mailContextMenus.js> (ThunderBird part)
[Checked in: Comment 31]


Could you (super-)review/check in this patch ? Thanks.
Attachment #151842 - Flags: superreview?(mscott)
Attachment #151842 - Flags: review?(mscott)
Comment on attachment 144270 [details] [diff] [review]
(Bv1-SM) <mailContextMenus.js> (SeaMonkey part)
[Checked in: Comment 30]


Check in: { 2004-06-28 01:43	neil%parkwaycc.co.uk	mozilla/ mailnews/
base/ resources/ content/ mailContextMenus.js	     1.51 }
Attachment #144270 - Attachment description: (Bv1-SM) <mailContextMenus.js> (SeaMonkey part) → (Bv1-SM) <mailContextMenus.js> (SeaMonkey part) [Checked in: Comment 30]
Attachment #144270 - Attachment is obsolete: true

Comment 31

15 years ago
attachment 151842 [details] [diff] [review] checked into the 1.0 branch and the trunk for Thunderbird.
Thanks for the patch!
Whiteboard: fixed-aviary1.0

Updated

15 years ago
Attachment #151842 - Flags: superreview?(mscott)
Attachment #151842 - Flags: superreview+
Attachment #151842 - Flags: review?(mscott)
Attachment #151842 - Flags: review+
Attachment #151842 - Attachment description: (Bv1-FF) <mailContextMenus.js> (FireFox part) → (Bv1-TB) <mailContextMenus.js> (ThunderBird part) [Checked in: Comment 31]
Attachment #151842 - Attachment is obsolete: true

Comment 32

15 years ago
Verified with
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040710
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.