coolquotescollection.com - CSS colors ignored due to invalid syntax

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
P4
minor
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: Dan Backes, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030530
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030530

On the given website, there is a keyword search field. When I type in that field
(it appears white to me), I cannot see my text because the website has the text
for that field set to the color white. This works okay in IE because the input
field's backgroud color is blue, but in mozilla the background color is white so
one cannot see the text that they have typed unless they highlight it.

Reproducible: Always

Steps to Reproduce:
1. Goto http://www.coolquotescollection.com/cat/computer/10/
2. Look at the keyword search field

Actual Results:  
The background color for the field is white.

Expected Results:  
The background color should be blue.

Comment 1

15 years ago
This is because the CSS that styles the INPUT box is using invalid syntax thst
Mozilla is ignoring:

INPUT.menu		{ background-color: '#004580'; border-color: '#005590'; 
color: white; }

There should be no quotes around the hex colors. Opera 7 also correctly ignores
the invalid syntax.

->TE
Assignee: form → susiew
Status: UNCONFIRMED → NEW
Component: Layout: Form Controls → US General
Ever confirmed: true
Priority: -- → P4
Product: Browser → Tech Evangelism
QA Contact: desale → zach
Summary: <input type="text"> background color remains white → coolquotescollection.com - CSS colors ignored due to invalid syntax
Version: Trunk → unspecified

Comment 2

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us
Problem not found
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.