frame displays html source of next frame in highly nested frameset - Conn Accept -Ranconn

RESOLVED DUPLICATE of bug 207897

Status

()

Core
Layout: HTML Frames
RESOLVED DUPLICATE of bug 207897
15 years ago
15 years ago

People

(Reporter: Bob Hahn, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

In the page at concinnate.com, each frame is filled with a simple html page that
displays its name, i.e. "I am banner.php." The problem starts in frame "banner"
when the text "Conn" arrives from space after the </html> tag in banner.php. The
word "Conn" is followed by the source of the next file to be loaded,
"seminarlist.php" which is intended for the next frame in the frameset. Instead
both go into frame "banner".

The frame "seminars", which is what was supposed to get seminarlist.php, gets
filled instead with viewer.php, whose </html> tag is followed by a second
Message From Space, "Accept-RanConn". The next frame in the sequence,
"blackboard" then fills with -and displays- the source code of player.html. That
same source file (player.html) is also correctly routed to the frame "player"
where it displays as intended.

This phenomenon goes away after several refreshes, and then stays away until the
cache is cleared.

BTW, the frameset and all the pages pass CodeSweeper and all those other
validation toys in HomeSite. 

Reproducible: Always

Steps to Reproduce:
1. Clear cache
2. visit http://www.concinnate.com/frametest.html
3.

Actual Results:  
html files routed to wrong frames, one frame displays html source of following
frame.

Expected Results:  
load the files into the frames, one file per frame.

*** This bug has been marked as a duplicate of 207897 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.