Attempts to drag (move) a line from tree control (thread pane, bookmarks, etc) hang client

VERIFIED FIXED

Status

()

Core
XUL
--
blocker
VERIFIED FIXED
15 years ago
10 years ago

People

(Reporter: Ralph Alvy, Assigned: Bienvenu)

Tracking

({hang, regression})

Trunk
x86
All
hang, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

6.92 KB, text/plain
Details
997 bytes, patch
janv
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a; MultiZilla v1.1.32 final) Gecko/20030601
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a; MultiZilla v1.1.32 final) Gecko/20030601

Attempts to drag (move) a message from InBox to another folder locks Mail
client. Haven't seen this until this build.

Reproducible: Always

Steps to Reproduce:
1. Mouse select a message in InBox
2. Drag to a folder
3.

Actual Results:  
Lock up.

Expected Results:  
Obvious
and which build Do you use ?
This bug is invalid if rv:1.3a because it's to old.
(But the UA string could be wrong due to multizilla)
(Reporter)

Comment 2

15 years ago
It's found in Build 2003060108. I thought I posted the bug report with that
build. Apparently not.
(Reporter)

Comment 3

15 years ago
Reporter again: the build 2003060108 is the one dowloaded as the latest Nightly,
even though it reports rv:1.3a

Comment 4

15 years ago
Reproducible with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a)
Gecko/20030601

Comment 5

15 years ago
Confirming with linux 2003060122 trunk
wfm with 2003053122
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 6

15 years ago
Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a)
Gecko/20030601
Using the context menu's "Move To" works though.
Severity: normal → blocker
Keywords: hang, regression
This bug _IS_ confirmend for all platforms (win32, Linux..) and we don't need
new "confirmed ..." comments - Thanks

regressioin between 2003053122 and 2003060122

Comment 8

15 years ago
Just tested buildID 2003060104 and no hang but does happen on buildID 2003060108
on Win XPSP1, so regression happens sometime between those two builds.

Comment 9

15 years ago
So bug 207798 is the cause.

Comment 10

15 years ago
ccing bienvenu@netscape.com
(Assignee)

Comment 11

15 years ago
I'm not able to reproduce this - I'll keep trying.

Comment 12

15 years ago
Created attachment 124732 [details]
stacktrace during hang
(Assignee)

Comment 13

15 years ago
thx, yeah, I thought so. It wasn't my checkin. It was timeless. That explains
why the move menu worked but drag+drop failed.

http://bugzilla.mozilla.org/show_bug.cgi?id=207318
(Assignee)

Comment 14

15 years ago
I'm updating my tree to get timeless'es change to make sure that backing him out
fixes things. You might try things like drag drop in the bookmarks window to see
if it has the same problem.

Comment 15

15 years ago
Ok, bienvenu, sorry for wrongly accusing you... it looked so close, but when I
looked at your patch I almost knew it couldn't be that one...
Bug 207603 and bug 207318 are the other checkins during the time in question and
my next guess would be the latter one...

Comment 16

15 years ago
Well there are certainly some bugs opened recently to do with hangs in there, so
maybe this bug's summary/component/etc need to be tweaked and some duping done.

Comment 17

15 years ago
For example bug 207940 and bug 207964
(Assignee)

Comment 18

15 years ago
adjusting summary
Component: Mail Window Front End → XP Toolkit/Widgets: Trees
Product: MailNews → Browser
Summary: Attempts to drag (move) a message from InBox to another folder locks Mail client → Attempts to drag (move) a line from tree control (thread pane, bookmarks, etc) hang client

Comment 19

15 years ago
*** Bug 207940 has been marked as a duplicate of this bug. ***

Comment 20

15 years ago
*** Bug 207964 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
*** Bug 207943 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
*** Bug 207901 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
Also affects addressbook and personal toolbar

Comment 24

15 years ago
*** Bug 207981 has been marked as a duplicate of this bug. ***
From the patch in bug 207318:

> -  mView->GetParentIndex(mDropRow, &parentIndex);
> -  while (parentIndex >= 0) {
> +  while (NS_SUCCEEDED(mView->GetParentIndex(mDropRow, &parentIndex)) &&
> +         parentIndex >= 0) {
>      mValueArray.RemoveValue(parentIndex);
>      mView->GetParentIndex(parentIndex, &parentIndex);
>    }

That looks like a infite loop... (GetParentIndex called with mDropRow every loop)
(Assignee)

Comment 26

15 years ago
*** Bug 207987 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 27

15 years ago
I'll come up with a better patch than timeless'es.

the old code did NOT  have this call every time through the loop:

NS_SUCCEEDED(mView->GetParentIndex(mDropRow, &parentIndex)
(Assignee)

Comment 28

15 years ago
Created attachment 124748 [details] [diff] [review]
proposed fix
(Assignee)

Comment 29

15 years ago
Jan, can I get a review for this fix? thx.
Comment on attachment 124748 [details] [diff] [review]
proposed fix

sr=sspitzer, once you get jan to review.

thanks for fixing this, david.
Attachment #124748 - Flags: superreview+
Attachment #124748 - Flags: review?(varga)
over to david.
Assignee: sspitzer → bienvenu

Comment 32

15 years ago
Comment on attachment 124748 [details] [diff] [review]
proposed fix

bah, mea culpa for not catching this while I was reviewing timeless's patch
r=varga
Attachment #124748 - Flags: review+
(Assignee)

Comment 33

15 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 34

15 years ago
Just to confirm I verified this bug was not in the branch builds 6-1 and 6-2. Esther

Comment 35

15 years ago
*** Bug 208053 has been marked as a duplicate of this bug. ***

Comment 36

15 years ago
*** Bug 208091 has been marked as a duplicate of this bug. ***

Comment 37

15 years ago
*** Bug 208105 has been marked as a duplicate of this bug. ***
*** Bug 208116 has been marked as a duplicate of this bug. ***

Comment 39

15 years ago
*** Bug 208054 has been marked as a duplicate of this bug. ***

Comment 40

15 years ago
V. 2003060304 PC/WinXP
Status: RESOLVED → VERIFIED

Comment 41

15 years ago
Verified internally using 20030503 trunk build on winxp.

Comment 42

15 years ago
*** Bug 208206 has been marked as a duplicate of this bug. ***

Comment 43

15 years ago
From my point of view fixed with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030604
Thanks, Wolfgang
(Assignee)

Comment 44

15 years ago
*** Bug 209186 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 45

15 years ago
This bug has resurfaced with Build 20030614, however to make it happen, you must
Select more than one message in the InBox and then attempt to drag both to
another folder at one time. I have done this with 2 message Selected, repeatedly
causing a  crash.

Comment 46

15 years ago
Drag/drop moving of multiple bookmarks causes crash in Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.5a) Gecko/20030617 on Windows 2000.  Crash is
reproducible, and this problem does not seem to have remained fixed.
A crash is of course not fixed.
The summary is very clear "freeze" and see also the "hanf" keyword.
You would see the word "crash" if this also fixed a crash.

Comment 48

15 years ago
if you're experiencing *anything* with a current build, then it isn't this bug.
please find some other bug in which to discuss your problem.
(Reporter)

Comment 49

15 years ago
From reporter: Based on the very last comment, I'm not sure if I should begin a
new bug on this. Though the original bug I reported involved a *hang* when
moving a *single* message from InBox to a folder, I only recently noticed that,
even though the latter was fixed, a *crash* occurs if moving *two* messages from
the InBox to a folder at the same time.

Comment 50

15 years ago
ralph: sorry, your bug was hijacked, file a new one.

Updated

15 years ago
Attachment #124748 - Flags: review?(varga)

Comment 51

15 years ago
This problem (as originally reported, as I understand it) was fixed in some
builds, as recently as 20030618 under MacOSX.  Broken again in 20030620.

Bug 208147 seems to track a similar problem.

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: esther → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.