Moving or deleting message from IMAP folder does not complete (intermittent)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: rtrout, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

Using Moz 1.4 RC1, Windows 2000, on IMAP folders to Ipswitch IMail server.
Problem first occured in Moz 1.3 final, and symptoms identical.

Problem is attempting to move, copy or delete message/s from IMAP folder do not
complete, ie. messages stay there and Mozilla does not appear to acknowledge
command in any way. No tests on POP, but moving messages in Local Folders works
fine.

What is strage is that the problem only begins some time (approx 30 minutes)
after beginning to use Mozilla/Mail News. Restarting clears fault every time,
but closing/opening Mail News while Mozilla remains running does not work.

My suspicion is that fault is somehow related to Junk Mail controls as it
usually happens most often first thing in the morning when my Inbox has 50-100
messages many of which are SPAM. During the rest of the day, the bug does not
appear to occur.

I can't give exact details of how to reproduce, other than I suspect IMAP,
possibly Ipswitch Imail (I reported previous bugs on Imail that were fixed -
great work guys), and Junk Mail controls. Remember that fault is not always
present but happens some time after starting.

Reporting as Normal bug severity as workaround exists (restart Mozilla) but
impact is high as move/copy/delete such a commonly used critical function.

Note: not a dupe of 199299 as Mozilla does continue to function in other ways.

Reproducible: Sometimes

Steps to Reproduce:
See above.
1. Using Ipswitch Imail and Moz 1.3 or 1.4 RC1.
2. Login to IMAP and allow Junk Mail controls to run (generaly 30+ messages).
3. Select message in Inbox or other IMAP folders
4. Use Move, Copy or Delete from any menu to Local Folders or other IMAP folder.

Actual Results:  
Absolutely no response by Mozilla to acknowledge command issued.

Expected Results:  
Completed move/copy/delete
(Reporter)

Comment 1

16 years ago
*** Bug 207909 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

16 years ago
Richard, can you get me access to a test account on this server?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

16 years ago
Yes - email to bienvenu@netscape.com with account details.
(Reporter)

Comment 4

16 years ago
Email to bienvenu@netscape.com failing - will retry or please advise email
address for account details.
(Assignee)

Comment 5

16 years ago
Do you have the junk mail controls set to move messages to a junk folder? If so,
is that junk folder on the imap server or local?

Once this bug happens, is it the case that you can't move a message from the
imap folder to any other folder, or to a particular folder? In other words, if
you can't move it to folder A, can you move it to folder B? Mozilla keeps track
of whether a folder currently has messages being moved/copied into it, and if
so, doesn't allow another move/copy operation into that folder. Does it seem
like that's what's going on?
(Reporter)

Comment 6

16 years ago
Hi David

Yes, Junk Mail Controls move messages to a Local folder, and they are successful
in this until the bug occurs. Once the bug occurs, the messages get marked, but
are not moved.

The following are examples of what doesn't work:
Moving or Copying a message from an IMAP folder to an IMAP folder
Moving or Copying a message from an IMAP folder to a Local folder
Deleting messages in an IMAP folder (Mail and News Server prefs set to 'Move to
the Trash Folder' on delete)

I think these problems appear to occur to all IMAP folders but I am yet to test
to confirm this - I certainly spend most of time in my Inbox, but do use another
dozen or so IMAP folders and would expect that I had seen the fault localised to
certain folders if that was the case. Will update with more info next time fault
is reproduced.

What does work:
Moving or Copying a message from a Local folder to a Local folder
Deleting a Local folder

Sorry, have not tested with POP inbox.
(Reporter)

Comment 7

16 years ago
Over the last week, have been observing Mozilla's behaviour now that I have read
Comment #5, it does appear as if a particular IMAP folder 'hangs'.  
(Reporter)

Comment 8

16 years ago
Ok, the bug has appeared a couple of times this morning, which provides me more
info.

It appears to happen more at the beginning of the week, when I have more Junk
Mail the controls are sending to my (Local) Junk mail folder. However rather
than a 'load' issue it may simply be that there is a greater likelihood of an
operation getting 'stuck'.

And yes David, in your Comment #5, I think you were spot on - it does appear to
be specific folders in which Mozilla believes operations are completing. And now
that I know this, I appear to be able to break the deadlock - which appears to
be if I perform operations in other folders or perhaps it may be as simple as a
timeout (still testing, need more data to confirm, my gut feel says its the
other operations, as I should've noticed the timeout working well before I
created this bugzilla).
(Assignee)

Comment 9

16 years ago
one thing that can "un-stall" stuff is check for new mail - depending on your
check for new mail interval, this can appear fairly random. One thing that can
happen is that junk mail can have embedded nulls which the imap server sometimes
passes on to the client (which it's not allowed to do by the rfc, but some
servers do anyway). This causes us problems. I'd ask for an imap protocol log,
but if this is hard to reproduce, it might be hard to get a log.
(Reporter)

Comment 10

16 years ago
Hi David

Get New Messages doesn't appear to work for me at the moment, but perhaps it
also requires that there are messages on the server? The couple of tests I have
made are with no new messages.

Other notes:
* I can appear to SOMETIMES break the deadlock if I go to another IMAP folder
and move a message from there to a Local Folder.
* I sometimes also have a problem with sending a message, and Mozilla fails to
save to the (Local) Sent folder. This may be related but I can't make the
relationship between the IMAP Inbox and Local Sent folders - I don't move
messages between them.
Product: MailNews → Core

Comment 11

13 years ago
is this still a problem?

Comment 12

12 years ago
reporter appears to be gone
(Reporter)

Comment 13

12 years ago
Reporter is still here!

Mozilla has moved on a long way, and David did manage to make some IMAP improvements. Don't have the problem any more (although maybe doesn't appear because we're not using Junk Mail Controls).

I'm going to mark as WorksForMe as I don't know any better.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.