dead keys not working ^e^a`e`a¸c

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: stephaneg47, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Since about 2 weeks, dead keys are not working in my installation of Mozilla
anymore. As soon as I type an accent or cedil caracter (ex.: `^,¨,¸), the
character is printed as a standalone character before I can type the letter to
accentuate. This problem is everywhere in Mozilla (forms, address bar, mail,
composer, etc...) but nowhere in any other program that I'm using (graphical
text editors, Opera, OpenOffice, Quanta, etc...). It's ONLY in Mozilla. Doing a
copy-paste from another application works.

I don't know when the problem started exactly, but it must be due to a Red Hat 8
update from the RedHat Network.

The problem exists AT LEAST in versions 1.3, 1.3.1, 1.4 Beta and 1.4 RC1, no
matter with the Net Installer or the pre-compiled Tar archive.

This is pretty critical for those of us who need accents in their language, as
we have to compose our text in a text editor and paste it to Mozilla when we
think we're done...

Reproducible: Always

Steps to Reproduce:
1.anywhere in Mozilla, type a dead key, for example a grave accent `
2.type a letter
3.Mozilla should print è but instead prints `e

Actual Results:  
Mozilla prints the accent as one character and the letter as another character,
for example `e

Expected Results:  
The dead key should not print anything and a è should be printed after I typed
the "e" letter.

Red Hat Linux 8.0 with all the latest system updates from the RHN (RedHat
Network) as of 2003/05/29.
What is your LANG?
(Reporter)

Comment 2

16 years ago
My system is installed in French Canadian. LANG locale is fr_CA.UTF-8

Comment 3

16 years ago
I have the same problem with the dead keys. In all other linux applications
(OpenOffice 1.01, konsole... in KDE3 and console mode, Gnome not tested) dead
keys work correctly, but not in mozilla. International characters (chinese and
so) are displayed correctly if the corresponding character coding option is set,
and so do "dead keyed" characters (like "à"). But when trying to type in mozilla
(form, mail, composer, even in the adress form below) deadkeys don't work.
There's an exception: when I copy a character or string from any other
application and paste in the composer, accents and other characters keep their
properties i.e. they are not typed as "´e" but "é".

I've tried to solve it by switching to lower-versions of mozilla, but from
version 1.3 to 1.4rc1 the problem persists. I don't remember exactly when that
problem started, I think it was while upgrading from 1.4b to 1.4rc1, but at the
same time I was updating my system from the RHN (RedHat Network).

System information:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529
locale: (configured as Catalan)
LANG=ca_ES.UTF-8
LC_CTYPE="ca_ES.UTF-8"
LC_NUMERIC="ca_ES.UTF-8"
LC_TIME="ca_ES.UTF-8"
LC_COLLATE="ca_ES.UTF-8"
LC_MONETARY="ca_ES.UTF-8"
LC_MESSAGES="ca_ES.UTF-8"
LC_PAPER="ca_ES.UTF-8"
LC_NAME="ca_ES.UTF-8"
LC_ADDRESS="ca_ES.UTF-8"
LC_TELEPHONE="ca_ES.UTF-8"
LC_MEASUREMENT="ca_ES.UTF-8"
LC_IDENTIFICATION="ca_ES.UTF-8"
LC_ALL=

O.S.: RedHat 8.0 with all RHN updates until 2003-05-21

BTW, Bug 182229 could be the same as this one?

Thanks for your attention.
(Reporter)

Comment 4

16 years ago
It MAY be about the same as 182229, except that:
1) I did not try as old as Mozilla 1.0.0
2) I did not change my locale, it just stopped working at some point without any
big configuration change from my end, nor even a Mozilla upgrade. That's why I'm
suspecting one system update from the Red Hat Network, but I really don't know
which one it would be...
(Reporter)

Comment 5

15 years ago
Awesome! I confirm that the problem is fixed in the final 1.4 киакпоы!!!

Problem was still there in the release candidates (at least RC1 and RC2, I don't
remember if I had the time to give a try to RC3) but it seems to have been fixed
in 1.4 Final.

Thanks to everybody who worked on this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 6

15 years ago
Yes, finally it works for me too, but I don't think it should be for the 1.4
final release. I have installed that one and the rc3, and they didn't work
either. It was when I updated some packages from RedHat that dead keys have
started working again, so it makes me think that it was not a mozilla bug. BTW,
the packages I have updated are the XFree86 and the jre from 1.4.1 to 1.4.2.

Anyway, I also thank to everybody for the work.
(Reporter)

Comment 7

15 years ago
Very possible, me too I updated the XFree86 packages from the RedHat Network 2
or 3 days ago...

Anyway, it's working now! I can finally leave my text editor and write my
e-mails directly in Mozilla!!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.