We need a way to specify order of the template generated vs. XUL menu items

VERIFIED DUPLICATE of bug 20795

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 20795
18 years ago
18 years ago

People

(Reporter: cata, Assigned: Chris Waterson)

Tracking

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I have the following menu. I need to get the <More>, submenu to be the last item
(after the generated items) as opposed to the first one.

<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin/tasksOverlay.css"
type="text/css"?>



<!DOCTYPE  window SYSTEM "chrome://global/locale/charsetOverlay.dtd">


<overlay id="charsetOverlay"
 xmlns:html="http://www.w3.org/TR/REC-html40"
 xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

<html:script language="JavaScript"
src="chrome://global/content/charsetOverlay.js"/>

 <!-- Charset Menu -->
 <menu id="charsetMenu" value="&charsetMenu.label;"
datasources="rdf:charset-menu" ref="NC:BSCharsetMenuRoot">
        <template>
            <rule>
             <menupopup>
                <menuitem uri="..."
value="rdf:http://home.netscape.com/NC-rdf#Name"
oncommand="SetDefaultCharacterSet(event.target)"/>
             </menupopup>
            </rule>
        </template>

        <menupopup>
       <menu value="More"  datasources="rdf:charset-menu"
ref="NC:BMCharsetMenuRoot">
            <template>
                <rule>
              <menupopup>
                    <menuitem uri="..."
value="rdf:http://home.netscape.com/NC-rdf#Name"
oncommand="SetDefaultCharacterSet(event.target)"/>
           </menupopup>
                </rule>
            </template>
            <menupopup>
            </menupopup>
        </menu>
        </menupopup>
 </menu>

</overlay>
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

18 years ago
*** This bug has been marked as a duplicate of 20795 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 2

18 years ago
verified duplicate of 20795. obvious double post.
You need to log in before you can comment on or make changes to this bug.