Cannot Tab to Select Widgets in Form

RESOLVED DUPLICATE of bug 197193

Status

Camino Graveyard
HTML Form Controls
RESOLVED DUPLICATE of bug 197193
15 years ago
15 years ago

People

(Reporter: Chris Blackstone, Assigned: Brian Ryner (not reading))

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030601 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030601 Camino/0.7+

With Chimera 0.7, I could tab through all form widgets, including select lists. 
With the current nightlies I can no longer tab to give the focus to select
lists, radio buttons, or check boxes.

Reproducible: Always

Steps to Reproduce:
1. Go to web site with a form that has select lists, radio buttons, etc
2. Try to tab through all the widgets
3. 

Actual Results:  
The select list and radio button were not selected

Expected Results:  
all form lists should be able to get the focus

This is a regression from Camino 0.7
Full Keyboard Access is turned on in the System Preferences

Comment 1

15 years ago
I dunno what the plans are if Camino will switch back to the 0.7 method of tab
or not but...

This was taken from http://www.mozilla.org/unix/customizing.html

// Tab focus model bit field:
// 1 focuses text controls, 2 focuses other form elements,
// 4 adds links.
// Most users will want 1, 3, or 7.
user_pref("accessibility.tabfocus", 1);

Do the math 1 + 2 or 1 + 2 + 4 etc etc... 

Add that to user.js in ~/Library/Application
Support/Chimera/Profiles/default/randomstring.slt/
(Reporter)

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 197193 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.