missing bookmark folders in add bookmark menu if bookmark folder with empty string as name

VERIFIED DUPLICATE of bug 175294

Status

()

Firefox
Bookmarks & History
--
minor
VERIFIED DUPLICATE of bug 175294
15 years ago
15 years ago

People

(Reporter: Arno, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030513 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030513 Mozilla Firebird/0.6

In the Add Bookmark Menu's, in the "Create in:" drop down menu if a folder with
an empty string as a name exists all the folder that are after it in the list
can not be seen.

Reproducible: Always

Steps to Reproduce:
1. Open FireBird
2. Delete all bookmarks & folder in the bookmark manager save the root bookmark
folder and the Bookmarks Toolbar Folder
3. create a new folder in the Bookmarks Toolbar Folder
4. Rename the new folder to "" (effectively nothing the empty string) :)
5. create another folder called "My Bookmarks" (the name does not matter) in the
folder with no name
   create another folder called "Other Bookmarks" (the name does not matter) in
the root bookmark folder.
6. on any webpage then select "add a bookmark" or press CTRL+D
7. In the Add Bookmark Menu click on the "create in:" dropdown menu to open the
dropdown menu

Actual Results:  
I can't see any bookmark folder in the "create in:" drop down menu except
Bookmark and Bookmarks Toolbar Folder.

Expected Results:  
It should display all the bookmark folders in the right hiearchy.

This bug appears to be independant of the theme for now I've only tested it with
the default FireBird theme.

However this bug only occurs when a folder with an empty string as a name
exists. If the folder has a name (even an insignificant " " space char) the
problem is solved. It's more a minor annoyance since it requires to either drag
the bookmarks after having bookmarked them to the appropriate folder, or to
rename the folder with an empty string as a name to something else.
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030601 Mozilla Firebird/0.6

Simpler test case:

1. Open Manage Bookmarks
2. Pick a spot in the middle of the folders, right click and choose New Folder,
and delete everything from the Name field of the Properties window.  Click OK to
save this new folder.
3. Hit Ctrl-D to bookmark the current page, any folders in the hierarchy below
the nameless folder cannot be selected.
4. Delete the nameless folder to restore normal function.

Comment 2

15 years ago
This is a dupe of bug #175294 => resolving accordingly...

*** This bug has been marked as a duplicate of 175294 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.