If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot create a message compose window.

RESOLVED WORKSFORME

Status

MailNews Core
Composition
--
major
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: rasmuse, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529

On click Compose/Reply buttons, an error messagebox pops up.
This occurs every time after installing 1.4rc1, and disappears when reinstalling
1.3.1. I have deninstalled from Control Panel first.


Reproducible: Always

Steps to Reproduce:
1. Install or start mozilla 1.4rc1
2. Open Mail window
3. Click Compose or Reply button 
(or select by menu/keyboard accel, or double-click a message in Drafts folder)

Actual Results:  
Compose/Reply reports: 
"An error occurred while creating a message compose window. Please try again."



I'm using Classic Theme, 
Mozilla as only browser, 
as default email client and browser etc, 
so no specialized config I can think of.
Reporter:
have you installed Mozilla in a clean (empty) directory ?
Summary: Cannot create a message compose window. → Cannot create a message compose window.
(Reporter)

Comment 2

15 years ago
Yes - just tried again. 
More:
When I hide all prefs files (prefs.js, prefs*.bak) in folder
   Windows/Application Data/Mozilla/Profiles/default/<secret-code>.slt/
and open mail, it seems to work again.
But this is only temporary. 
Steps:
Remove prefs.js and prefs*.bak
Restart mozilla -mail
Hit compose button. The compose window is opened, but on top of it
is the dialog to create a new account (since all my mail accounts and 
server settings are gone of course).
I create an account, the compose window is now available and functional.
But when I click Compose button next time, the error message is shown again,
so it's back to zero.

Sorry, but this is really a blocker for me...

Comment 3

15 years ago
I see this on Solaris 2.8 also.
blocker=blocks Mozilla development

This is worksforme with win2k build 20030602 and also wfm for many other people.

a) be sure that you install in a complete empty directory (and not only
uninstalled Mozilla) 
b) try a new, additional test profile

Comment 5

15 years ago
I also see this problem. I did an upgrade from 1.4rc1 - I will try reinstall
into fresh directory - but I think it's more to do with profile problem.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

Comment 6

15 years ago
I did install into a fresh directory on Solaris the first time.A new profile
makes this work again, but that is a bad solution.  As a user, I think creating
a new profile for every mozilla version is a pain, I counted 29 boxes I had to
click and 15 text fields I had to enter data into before I came back to what I
had (and I still do not get my saved passwords).
Reporter:

This is "worksforme" if it works with a new profile.
(Unless you find the reason for this in your broken profile and or
staff@mozilla.org changes the current way to solve such bugs)

files which could affect this (possible):
pancea.dat, localstore.rdf, xul.mfasl/xul.mfl,  chrome\*.*

-> wfm (broken profile)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.