If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ViewSource window could have line numbers

RESOLVED DUPLICATE of bug 15364

Status

Core Graveyard
View Source
--
enhancement
RESOLVED DUPLICATE of bug 15364
15 years ago
7 years ago

People

(Reporter: Evgeniy Karyakin, Assigned: Doron Rosenberg (IBM))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030526 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030526 Mozilla Firebird/0.6

It will be usefull to have line numbers in a ViewSource window to have more
comfort while you develop. For example, when you've been alerted about an error
in line X column Y, you will not have to copy entire source into some IDE to
seek this line.
By the way, as far as source is printed with monospaced font, it should be easy
to draw lightweight vertical lines dividing a source into columns of, say, 10
symbols. I mean, do it like it's done in M$ Word -- horizontal and vertical
rules makes your text more eyes-browsable. And of course this feature may be
optional.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Please do a Bugzilla query before filing a bug. The original bug wasn't very
hard to be found.

*** This bug has been marked as a duplicate of 15364 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Sorry for duplicate... But I still have an enhancement -- we should divide a
source into columns of some number of symbols to quickly find not only a line
with an error, but also a column number.

*** This bug has been marked as a duplicate of 15364 ***

*** This bug has been marked as a duplicate of 15364 ***
Product: Browser → Seamonkey

Updated

7 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.