News will not display threaded view - sometimes forgets "view-messages-unread" as well

RESOLVED DUPLICATE of bug 209534

Status

RESOLVED DUPLICATE of bug 209534
15 years ago
14 years ago

People

(Reporter: tony.aj.green, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

This problem seems mainly to manifest itself on newsgroups that have a lot of
messages (read or unread) in them - smaller newsgroups don't seem to be affected.

It seems initially possible to select "view - sort by - thread" but the
newsgroup will not display in a threaded manner. Clicking the various headers
within the window sorts correctly, but clicking the thread/non-thread toggle has
no effect (although the display does wobble a little.)
Looking again at "view - sort by" shows thread selected but greyed out.
Newsgroups exhibiting this problem also sometimes seem to forget that I've
selected the option to only view un-read messages, so that every time I go to
those newsgroups I see all messages. This is happening in 1.4 RC1 and also 1.4
beta on Windows AND Linux.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Tony Green: the View|Sort by|Thread item is greyed out if you are using a 
MailView (the dropdown list over the thread pane) or a QuickSearch -- for 
instance, if you have selected "Unread" there, you cannot view threaded.  If 
that is your situation, then this is a duplicate of bug 135326.

Comment 2

15 years ago
Tony Green, I have determined that your bug is basically correct as far as 
describing new behavior.  The part about being unable to select Sort by Thread 
after selecting View Messages Unread is what this bug is getting duped to; the 
part about "forgetting the unread" is, I think, bug 206131.

*** This bug has been marked as a duplicate of 209534 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.