Filter to kill/ignore branch of newgroup thread instead of killing entire thread

RESOLVED DUPLICATE of bug 11054

Status

--
enhancement
RESOLVED DUPLICATE of bug 11054
16 years ago
10 years ago

People

(Reporter: rob.stow, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030523 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030523 Mozilla Firebird/0.6

For trolls in newsgroups it would be *very* handy to be have the ability to not
only filter out the troll, but also any replies to the troll, replies to the
replies, etc, ...

Currently you can only kill either the troll, or entire threads that the troll
posts to.  However, if the troll interjects his comments into the middle of a
good thread you are royally screwed because filtering out only his comments
doesn't filter out the idiots (AKA troll feeders) that reply to him, yet the
only other option (killing the thread) is overkill because other branches of the
thread could contain worthwhile content.

The text on the filter options list could be placed immediately after the
"Ignore Thread" option and perhaps be labelled "Ignore Thread Branch".

In honour of my source of inspiration, we could perhaps call this the "Andkon
Bug"  :-D


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
Awesome idea!

Suggested keyboard shortcut: SHIFT-k

Suggested menu location: Message | Ignore Thread Branch (below "Ignore Thread")

We'll need an icon too. It should be on the post that is SHIFT-k'd (visible only
when "View | Threads | Ignored Threads" *is* selected, otherwise that whole
branch would be hidden).

Comment 2

16 years ago
*** Bug 208169 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

16 years ago
Re: Comment #2

How the heck was bug #208169 created ?   *I* sure as hell didn't do it, yet it
is a word-for-word duplicate of this bug (208137).   Should I be filing a bug
about Bugzilla somehow automagically producing spurious duplicates ?  As to why
it would do this almost 4 hours after I created 208137 ?????

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 11054 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Bug 207124 would be a more positive solution to the problem.

Gerv
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.