CSS2 System Fonts are not used when innerHTML is copied from a IFRAME to a DIV

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Andres C. Rodriguez, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529

To display dynamic tooltips, I use an IFRAME to load some HTML, and then copy
that to a floating DIV using the innerHTML property.  When the HTML uses the
CSS2 system fonts (i.e. "font: icon;"), the HTML is rendered correctly in the
IFRAME (when I make it visible), but not in the DIV.  The DIV seems to
completely ignore the style.  Just to be sure, IE handles it correctly.  The
problem is present on all the versions of Mozilla and Netscape that I have been
able to try it on.

Reproducible: Always

Steps to Reproduce:
1. Load a page into an IFRAME, that has some CSS2 system fonts styling.
2. Copy the innerHTML from the IFRAME to an absolute positioned DIV, after the
IFRAME finishes loading.


Actual Results:  
The DIV renders incorrectly.

Expected Results:  
The DIV should render exactly as the IFRAME did.

Comment 1

15 years ago
Can you attatch a testcase or URL?
Andres, I'm afraid I have to mark this bug worksforme (because it does -- the
rendering I see is identical when I try what you suggest).  Please reopen if
this is still a problem (and attach a testcase if so).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.