In the Selection List Properties dialog , the OK button is not being activated after modifying list item

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: chrispetersen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build: 2003-06-03-05
Platform: All
Expected Results: The Ok button should be activated after modifying the list item
What I got: After changing list item name, the OK button in dialog remained dimmed.

Steps to reproduce:

1) Open attached test case in Composer
2) Change the name of the first list item
3) After this is done, notice the OK button isn't activated.
(Reporter)

Comment 1

16 years ago
Created attachment 124843 [details]
select element for test
(Reporter)

Updated

16 years ago
Summary: In the Selection List Properties dialog , the OK dialog is not being activated after modifying list item → In the Selection List Properties dialog , the OK button is not being activated after modifying list item

Comment 2

16 years ago
Ryan, Neil--can one of you take this bug?

Comment 3

16 years ago
The behaviour is because your <select> doesn't have a name= which was originally
deemed to be necessary. Similarly you can't OK a <textarea> without specifying
name=, rows= and cols=, or a <input> without specifying a name=, except
type="radio" which needs both name= and value=, type="image" which needs src=
instead, and for type="submit" and type="reset".

Note that the DTD only requires rows= and cols= for textarea and src= and alt=
for input type="image"; the other values were probably enforced because they
make little or no sense. If you feel this is wrong then feel free to specify
better behaviour when you reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.