If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

hangs on attempt to load the URL given above

RESOLVED FIXED

Status

()

Core
XML
--
critical
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Kirill Lapshin, Assigned: Darin Fisher)

Tracking

({hang, regression})

Trunk
hang, regression
Points:
---
Bug Flags:
blocking1.7 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

The page http://openmathtag.sourceforge.net/OMT_demo_interactive.php loads just
fine in Mozilla Browser, but Firebird hungs trying to load it.
I tried it several times on two computers, so it gotta be easily reprodycible bug.

Reproducible: Always

Steps to Reproduce:
1. Visit http://openmathtag.sourceforge.net/OMT_demo_interactive.php
2.
3.

Actual Results:  
Firebitrd hungs, the tab with page does not even rotate the loading icon,
windows classifies Firebird as [Not Responding] application.

Expected Results:  
Show page correctly like full Mozilla browser does.
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030603 Mozilla Firebird/0.6

Also confirmed on Mozilla 1.4 RC1, so this is not FB specific and should
probably be reassigned to Browser-General for triage (I don't know where this
goes, and I don't know enough about MathML to build a test case in any logical
fashion).
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030603 Mozilla Firebird/0.6

Also confirmed on Mozilla 1.4 RC1, so this is not FB specific and should
probably be reassigned to Browser-General for triage (I don't know where this
goes, and I don't know enough about MathML to build a test case in any logical
fashion).

Comment 3

15 years ago
This is very weird: I was able to reproduce this using Mozilla/5.0 (Windows; U;
WinNT4.0; en-US; rv:1.4b) Gecko/20030603 Mozilla Firebird/0.6.

Next I tried SeaMonkey Gecko/20030603 and was able to reproduce this, too.

Then I went back to some early 2003-03-xx builds and there the page was
rendered, together with an error message, that I need to install some special
fonts. So I checked all subsequent builds of SeaMonkey to find the last good
build where the page was displayed and now even with Gecko/20030603 the page
gets renederd... Also a reboot doesn't bring the hang back.

Comment 4

14 years ago
-> critical
-> hang

I'll move this to 'browser' product. (or just a dup.)
Severity: normal → critical
Keywords: hang, qawanted

Comment 5

14 years ago
Confirming this bug still exists in Firebird 20030729

Comment 6

14 years ago
Moving to browser, I'll mark as new as soon as I can get a more recent nightly.
Component: General → Browser-General
Product: Firebird → Browser
Version: unspecified → Trunk

Comment 7

14 years ago
Tried this URL on Linux (Debian 3.0 stable) with 0.6.1. The Browser hung,
indicating that this is not an OS specific problem. Top indicated that it was
using little on no CPU.

Comment 8

14 years ago
OS / Hardware -> All
OS: Windows XP → All
Hardware: PC → All

Comment 9

14 years ago
Just a few additional comments, the bug seems to have nothing to do at all with
either the stylesheet, or the code, but seems to be part of the headers sent or
something else, but I havn't been able to track it down :( This might still be a
duplicate... but I can't cross check enough to be sure.

Comment 10

14 years ago
Created attachment 131807 [details]
stacktrace

??
PR_Wait
PL_WaitForEvent
nsEventQueueImpl::WaitForEvent(PLEvent**)
nsSyncLoader::PushAsyncStream
nsSyncLoader::LoadDocument

Comment 11

14 years ago
this regressed between linux trunk 2003032505 and 2003032604

loading locally did not exhibit the bug.

==> XML
Assignee: blake → hjtoi-bugzilla
Status: UNCONFIRMED → NEW
Component: Browser-General → XML
Ever confirmed: true
Keywords: qawanted → regression
QA Contact: asa → ashishbhatt
Is this still present in Firefox 0.8?
Summary: Firebird hungs on attempt to load the URL given above, Mozilla loads it just fine. → Firefox hangs on attempt to load the URL given above, Mozilla loads it just fine.

Comment 13

14 years ago
It is present in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113, which means it should be in Firefox 0.8 as well.

Updated

14 years ago
Summary: Firefox hangs on attempt to load the URL given above, Mozilla loads it just fine. → hangs on attempt to load the URL given above

Comment 14

14 years ago
Still existent in Mozilla 1.7rc1. Shouldn't this bug be a blocker for 1.7 final?
Flags: blocking1.7+
I doubt this is a blocker candidate, its not really high-visibility.

in any case, it should be ?, not + (drivers set +)
Flags: blocking1.7+ → blocking1.7?

Updated

14 years ago
Flags: blocking1.7? → blocking1.7-

Comment 16

13 years ago
Confirming this still exists in Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US;
rv:1.7.5) Gecko/20041107 Firefox/1.0
(Assignee)

Comment 17

12 years ago
This problem will be solved by my patch for bug 326273.
Depends on: 326273
(In reply to comment #17)
> This problem will be solved by my patch for bug 326273.
> 

Confirmed, works fine now
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060510 Minefield/3.0a1 ID:2006051013 [cairo]
(Assignee)

Comment 19

12 years ago
-> me
Assignee: hjtoi-bugzilla → darin
(Assignee)

Comment 20

12 years ago
FIXED
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.