JavaScript swapimage does not appear to work.

CLOSED WORKSFORME

Status

SeaMonkey
General
CLOSED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Rob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030603
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030603

When the links are pressed to 'javascript:swapimage('photo')' the photo never
changes.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.transpave.com
2.SelectEnglish,then Landscaping, then Retaining walls, then Garden Block
3.Select the links for '<<Photos: 1 2 3 4'

Actual Results:  
Nothing happens when the links are pressed

Expected Results:  
The photos in the frame to the left should change.

I've tried this link using Mozilla 1.2, 1.3.1, and the latest build. They all do
not work. Konqueror from kde 3.1 works.

Comment 1

15 years ago
WFM on WinXP 2003053108.

Comment 2

15 years ago
WFM 2003060308

Comment 3

15 years ago
WFM Linux and WinNT 20030523xx. Reassigning to Browser-General.

Rob:

1. What settings do you have in Edit > Preferences > Advanced > Scripts&Plugins?
   Do you have "Allow scripts to change images" checked?

2. If so, then try creating a brand-new Mozilla profile:

          [ ] ./mozilla -profilemanager 

   Does the problem still occur with the new profile? 


3. If 2. doesn't work, are you getting any errors in
   Tools > Web Development > JavaScript Console ? 
   (be sure to clear it of any previous errors first)
Assignee: rogerl → general
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → general
Summary: javascript swapimage does not appear to work. → JavaScript swapimage does not appear to work.
(Reporter)

Comment 4

15 years ago
As Phil suggested:
Edit > Preferences > Advanced > Scripts&Plugins
"Allow scripts to change images" was not checked.

Actually, none of the boxes were checked. Should they be checked by default?
Perhaps my profile has been around for too many versions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 5

15 years ago
Nothing in Mozilla was broken or fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 6

15 years ago
-> WORKSFORME as per comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

15 years ago
Just to clarify. This was NOT a bug. The problem was:

Edit > Preferences > Advanced > Scripts&Plugins
"Allow scripts to change images" was not checked.

Sorry for the inconvenience.

Rob
Status: RESOLVED → CLOSED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.