setting Mozilla as the "Open With" application causes infinite window opening

RESOLVED DUPLICATE of bug 167320

Status

SeaMonkey
Download & File Handling
--
minor
RESOLVED DUPLICATE of bug 167320
15 years ago
11 years ago

People

(Reporter: Proud, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

On any download, when Mozilla asks the user how to download the file, if the
user chooses the same Mozilla application that is running, Mozilla will proceed
to download the file in a new window. This action will repeat in the new window,
downloading the file to another new window, which will never end unless the user
closes all of those windows.

This is important because this could be done by user error or from a user
expecting Mozilla to handle the file internally for display. In either case, the
user does not expect the application to open an infinite number of windows
trying to process the file.

Reproducible: Always

Steps to Reproduce:
1. When downloading a file of a new type (i.e. first time I downloaded a .rtf or
.zip file), click on the "Open it with" option.
2. Click on the now enabled "Choose..." button.
3. Choose the same application you are running.
4. Confirm the 'choose' and 'opening' windows.
Actual Results:  
A new window pops up with a download box that, when the file is done saving,
creates a new window with the file. This action happens infinitely.

Expected Results:  
Mozilla should have either disallowed the user to select itself as a helper
application, or, as the user intention may have been, attempted to display the
document internally as best as possible (for example, I tried downloading a .rtf
file in hopes that Mozilla would display the page in rich text format, or if not
that, at least as plain text).

Comment 1

15 years ago
Martin, this can be also seen using Mozilla SeaMonkey (Windows; U; WinNT4.0;
en-US; rv:1.5a) Gecko/20030603 - hence this one belongs to Product "Browser".

Nevertheless this is an interesting effect :o)

Comment 2

15 years ago
Moving over to Browser
Assignee: blaker → general
Component: Downloading → Browser-General
Product: Firebird → Browser
QA Contact: asa → general
Version: unspecified → Trunk
(Reporter)

Comment 3

14 years ago
In Mozilla, the "always perform this action" check box must be clicked (or, in
the "helper applications" section of the preferences, the "always ask me" check
box for a particular type of file must be unchecked) in order for this to happen.

No one has confirmed this bug yet, but I still contend this is *always*
reproudicible. Although it is generally non-threatening and probably not
commonly encountered, a user could easily run into this thinking Mozilla can
handle the file internally (as I did! Silly me).

I wager this also occurs on other platforms as well, but I have a lack of
ability to test so (I'm also relatively new to Bugzilla... so I'm not entirely
sure what should be done, if anything...)
Summary: opening download window choose mozilla to open file opens infinite windows → opening download window choose opens infinite windows
tweaking summary to reflect what is really happening, moving to correct 
component.  not sure if this is a dupe, but moving out of the morass of browser-
general to hopefully increase the visibility.  There's a Firebird version of 
the bug for that download manager too.
Assignee: general → download-manager
Component: Browser-General → Download Manager
Summary: opening download window choose opens infinite windows → setting Mozilla as the "Open With" application causes infinite window opening

*** This bug has been marked as a duplicate of 167320 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.