Malformed mail message causes hang of mozilla (and several other problems)

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
critical
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: arnova, Unassigned)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

I occasionally have problems with moving large amount of emails from my
inbox(imap) to my local folders. At one point I could reproduce it so I did some
more investigation. It also tried moving FROM an imap-folder TO an imap-folder
and it didn't have this problem. After a day of testing it discovered that the
problem is/was caused by a single (spam)-message which was unreadable by Mozilla
mail. When I tried to read the message mozilla simply hangs or it shows the
animated busy-indicator ("busy-bar"). I think a lot of mail problems can be
tracked back to this issue. 

Because a move between 2 imap folders is performed at the low (server-)level
(which doesn't require mozilla to actually read the message itself), a corrupted
message doesn't pose a problem. But reading, moving, copying the message to a
local folder requires mozilla mail to read the message, which hangs mozilla

Reproducible: Always

Steps to Reproduce:
1. Try to "read" the corrupted message
2. 
3.

Actual Results:  
Mozilla hangs and sometimes it shows the busy-indicator (which keeps "running").

Expected Results:  
Mozilla should detect the message is corrupted or Mozilla should timeout after a
reasonable amount of time.

A have a sample file (folder) with a corrupted message in it.
(Reporter)

Comment 1

15 years ago
Created attachment 124888 [details]
Mozilla mail folder with corrupted message
(Reporter)

Updated

15 years ago
Flags: blocking1.4?

Comment 2

15 years ago
mozilla1.4 shipped. unsetting blocking1.4 request.
Flags: blocking1.4?
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 4

10 years ago
message reads fine from local folder with TB version 2.0.0.7pre (20070922), though it's already garbage.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: hang
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.