browser freezes when typing anywhere with in the browser



15 years ago
14 years ago


(Reporter: Sean T. Gillespie, Unassigned)



Firefox Tracking Flags

(Not tracked)





15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030401

Upon opening mozilla, I can click on bookmarks and such and it repsond no
problem, when I start typing a URL, it freezes with no alerts, or errors. Also
if I goto a URL with input fields and I start typing it still freezes. I have
installed Mozilla using the installer (with talkback) and also compiled from
source, in either case it still does it.

Reproducible: Always

Steps to Reproduce: terminal (using gnome-terminal) /usr/local/mozilla/bin/

Actual Results:  
The browser window opens, I start typing any URL in open location bar and it
becomes unresponsive, I have to kill the process it make the window go away. No
errors popup and their are no hidden windows, it just sits there. 

Expected Results:  
Allowed me to type, and continue

It's possible that it might have been caused by some updates I installed. I am
running Mandrake 9.1. However, I am running the same OS with the same updates on
my  notebook and have no problem with Mozilla. The only difference that I can
see between the two systems, is on my desktop, I am running with kernel
2.4.21-multimedia-18mdk and on my notebook I am running 2.5.69

Comment 1

15 years ago
I too have this same problem with 1.4.1b through 1.4.1rc2 (haven't confirmed about older 
versions).  It only started happening today when I upgraded to rc2 from 1.4.1b, which had 
been working well for a couple of months.  I tried moving my .mozilla dir and re-importing 
my old netscape profile, but it still freezes. 
I'm running Red Hat 9, fully erratafied, using the talkback installer. 
There is no CPU usage, but Mozilla is wholly unresponsive and must be killed to get rid 
of it. 
Flags: blocking1.4+

Comment 2

15 years ago
FWIW (not much, I'm sure), an strace shows: 
And just hangs.  I'm going to assume that corresponds to this from 'lsof | grep mozilla': 
mozilla-b 9366      joe   22u  unix 0xddcd2040             215546 socket 


15 years ago
Flags: blocking1.4+

Comment 3

15 years ago
this sounds like bug 198345.  can you try disabling type-as-you-find
(edit->preferences->advanced->keyboard nav) and see if the problem persists?

> I too have this same problem with 1.4.1b through 1.4.1rc2 

I'm willing to bet you had problems with 1.4b and 1.4rc2 and not 1.4.1
Severity: blocker → critical
Keywords: hang

Comment 4

15 years ago
You're right about the version.  Heavy drinking will do that for you...

The problem disappeared after a clean downgrade to 1.4b, and a system reboot.  I
think the system reboot is what did it, though I can't even guess why.  Nothing
else had issues, and browsing via clicks and bookmarks worked fine.

Comment 5

15 years ago
so - can the reporter (Sean) or anyone reproduce this with a recent build of
Mozilla?  if so, please comment again with details.  if not, this can be
resolved as WORKSFORME.

Comment 6

15 years ago
nobody said this is still broken, so resolving WFM.

please reopen if it's still a problem...
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.