Not allowed to add "art-lojban" in "Add languages" preferences

RESOLVED FIXED

Status

()

Core
Internationalization
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Martin Norbäck, Assigned: smontagu)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

www.lojban.org is available in lojban if you have "Accept-Language: art-lojban".
However, when I try to add this language in Preferences/Navigator/Languages/Add...
I get a dialog box saying: "Alert! Not a valid language code.". However, rfc
2616 (and rfc 2234 and rfc 3066) say that the allowed values of this header is:
language-range  = ( ( 1*8ALPHA *( "-" 1*8ALPHA ) ) | "*" )

art-lojban matches this, and so should be allowed.

Reproducible: Always

Steps to Reproduce:
1. choose Edit/Preferences...
2. choose Navigator/Languages
3. Press Add...
4. enter art-lojban in the Others: field
5. Press OK

Actual Results:  
An alert dialog pops up saying: "Alert! Not a valid language code."

Expected Results:  
Mozilla should accept this language code.
(Reporter)

Comment 1

14 years ago
Created attachment 124914 [details] [diff] [review]
proposed patch to bug 208277

this seems like a clear cut bug and easy to fix
(Assignee)

Comment 2

14 years ago
The fix seems reasonable, especially since the current code contradicts the
comment immediately above it. For the record, art-lojban is registered in IANA:
http://www.iana.org/assignments/lang-tags/art-lojban. Are you requesting review
or do you want to do more testing?
(Reporter)

Comment 3

14 years ago
Created attachment 124940 [details]
picture of it working :)

I don't think any more testing is needed, it works.
(Reporter)

Comment 4

14 years ago
Created attachment 124942 [details]
A nice picture of a bug in google

Just a bit of fun for you all. Google apparently uses only the two first
characters of the code to determine which language to use.

art-lojban matches ar which is arabic.
(Assignee)

Comment 5

14 years ago
Comment on attachment 124914 [details] [diff] [review]
proposed patch to bug 208277

r=smontagu
Attachment #124914 - Flags: review+
(Assignee)

Comment 6

14 years ago
If you get a super-reviewer (http://www.mozilla.org/hacking/reviewers.html), I
will be happy to check this in for you.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

14 years ago
I've sent mail as per the instructions in super-reviewer, but I haven't received
any answer. I don't know how to proceed.
(Reporter)

Updated

14 years ago
Attachment #124914 - Flags: superreview?
(Reporter)

Updated

14 years ago
Attachment #124914 - Flags: superreview? → superreview?(darin)

Comment 8

14 years ago
Comment on attachment 124914 [details] [diff] [review]
proposed patch to bug 208277

sr=darin
Attachment #124914 - Flags: superreview?(darin) → superreview+
(Assignee)

Comment 9

14 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

14 years ago
After checking this in I can add art-lojban to the preference, but it doesn't
work for me on http://www.lojban.org/ unless I remove all other languages. I
don't know if this is our bug or theirs.
You need to log in before you can comment on or make changes to this bug.