image border styles not rendered as specified in css

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
--
minor
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: Goetz Heller, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4) Gecko/20030529

Specifying border-style:outset of an image has no affect
Comparision: Works well with Opera 7.11 on Windows and Linux, Netscape Navigator
7.2 on Windows and Navigator 7.02 on Linux, IE 5.5/6.0

Reproducible: Always

Steps to Reproduce:
1.open the URL
2.have a look to the country flags
3.



Expected Results:  
the country flags should appear raised

Comment 1

15 years ago
Created attachment 125007 [details]
Simplified testcase

Well this simple testcase SHOWS that setting border-style works.
Need to go thru testcase some more.

NOTE: I did notice that the test "if (el.style.borderStyle == 'outset')"
always returns false

Comment 2

15 years ago
Created attachment 125008 [details]
Updated simplified testcase

Ok, I noticed in your css that you were stying border:0 for your image.
Doing this is definitely what is causing us to not update the border-style.
Now I need to see what the spec says about setting NO borders and then
later setting a border style.

Updated

15 years ago
Attachment #125007 - Attachment is obsolete: true

Comment 3

15 years ago
Ok, a little correction.  The testcase shows that setting border-style
works. but I was mistaken when I said you set border:0 for this element.

Comment 4

15 years ago
Created attachment 125408 [details]
new test case

This new test shows the problem as well.  OnLoad, we go thru init
and set the 1st & 3rd flag to be outset and the middle (2nd) to be
inset.	mozilla doesn't show anything.

I also added an onclick handler such that if you click on the 
flag, I change the borderWidth from thick->thin or from thin->thick.
Once you click on one of the images, the borderStyles ALL turn on.

This looks like a css-style inheriting/initialization issue

Comment 5

15 years ago
re-assinging to dom-style (I think this is the right component and owner)
note: the workaround is to add a border-width:thin to the style of the images
Assignee: jdunn → dom_bugs
Component: Image: Layout → DOM Style

Updated

15 years ago
Attachment #125408 - Attachment mime type: text/plain → text/html

Comment 6

15 years ago
Confirming bug, 2003-07-03-22 trunk Linux.  Using the DOM Inspector shows that
the computed style is correct but the border isn't displayed.
Forcing a reflow by zooming makes the border appear.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows NT → All

Comment 7

15 years ago
Bug does not occur in Mozilla 1.3.1:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030425

Comment 8

14 years ago
Specifying img{border:10px} will not give an image a border (it doesn't work in
IE either :P). However specifying border:0 will take a border off of an image
representing a link.
testcase 3 WFM (I think; it's not clear to me exactly what the problem is) in Firefox 3.0.  Can we close this old bug?
Assignee: general → nobody
QA Contact: tpreston → general
QA Contact: general → style-system
Yeah, seems to be fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Component: DOM: CSS Object Model → Style System (CSS)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.